Hyper-V and LoadBalancing with PFSense



  • Hello everyone.
    I've been searching here for a while and I've managed to solve many issues with PFSense and Hyper-V (including the one that the interface would not get up properly).
    It's working quite fine now.

    However there is still one thing that prevent's me from replacing the existing router with PFSense:
    I'm not able to do a true load balancing system.

    Not sure why but here is what I'vre tried. Maybe someone can help me a bit…  ;D

    1. The VM has 3 network adapters. 1 is shared with the host (LAN), the others (WAN) are not.
    2. After setting the PFSense to loadbalance I can get traffic on both WAN's.
    3. Then I disconnect one of the cables. PFSense does NOT reacts to this and the loadbalancing is lost. I have no internet connection anymore.
    4. I change the cable from WAN1 to WAN2. Keep disconnected. No warnings on PFSense.

    Now comes the tricky part:

    1. I replace all cables and connection is restored. Made a test to make sure it was ok.
    2. On Hyper-V configuration, changed the legacy network adapter from "Realtek (...) -> physical adapter" to "None".
    3. PFSense starts saying "de1: link down: cable problem?"
    4. During this I also have no internet connection.

    Some of my thoughs (that might be mistaken):

    -- Hyper-V Legacy Network Adapter is emulated (that I do know) and the status from the cable is not sent to to the VM. So there is no easy way for the VM to know if the cable is up or down except for ping or something like that.
    -- PFSense does a regular LoadBalace without failover OR a manual failover that I have to switch links manually. At least is what I got from the "Manual Failover" from the webConfigurator tool.

    Is there any way for PFSense to know that the cable is UP/DOWN?
    Is there a way also to set PFSense to LoadBalance + Failover and not simply one or another?

    Thanks.



  • you should create loadbalance/failover to get over that problem



  • WOW! Don't say!

    Maybe that's why I've posted
    "2) After setting the PFSense to loadbalance I can get traffic on both WAN's."
    ;D

    Now using 2.0 RC3 I can't choose much.
    All I have is "Load Balance" or "Manual Failover".

    Can you please tell me how on Earth I'm going to choose another mode from the drop-down list?
    8)



  • Sorry then i misread someparts, (almost half of your post)
    There have been some updates, when something small is broke for a day or so. after upgrade everything works well


Log in to reply