BlackBerry Bold 9900 has troubles associating



  • Hi,

    After reading up on how to configure my WLAN card to work with pfSense I have pretty much everything working properly with my laptop. Can access the internet, my local LAN so everything is just fine.

    Now however I would also like to associate my Bold 9900 to this network, it receives its IP address and appears to be connected; however it tries to reach some blackberry server on port 443 and does not seem to be successful at this. I tried to ping the gateway (192.168.10.1) from the phone and it doesn't ever get a reply. Doing this from my laptop works just fine. The device also keeps losing its connection and then tries to associate with the AP again, which is sometimes succesful.

    Tried removing WPA and same problem still occurs, though it must be something within the device but happened to stumble upon an unprotected WiFi hotspot; tried to connect and instantly worked. So something within pfSense appears to be blocking the device from function. This is what happens in the logfile what looks bad to me;

    
    Sep 11 00:55:35 	hostapd: ral0_wlan0: STA a0:6c:ec:92:07:43 IEEE 802.11: deassociated
    Sep 11 00:55:35 	hostapd: ral0_wlan0: STA a0:6c:ec:92:07:43 IEEE 802.11: deauthenticated due to local deauth request
    Sep 11 00:55:25 	dhcpd: icmp_echorequest 192.168.10.101: Host is down
    Sep 11 00:55:25 	hostapd: ral0_wlan0: STA a0:6c:ec:92:07:43 WPA: group key handshake completed (WPA)
    Sep 11 00:55:25 	hostapd: ral0_wlan0: STA a0:6c:ec:92:07:43 WPA: pairwise key handshake completed (WPA)
    Sep 11 00:55:25 	hostapd: ral0_wlan0: STA a0:6c:ec:92:07:43 RADIUS: starting accounting session 4E6BEA30-00000001
    Sep 11 00:55:25 	hostapd: ral0_wlan0: STA a0:6c:ec:92:07:43 IEEE 802.11: associated
    
    

    192.168.10.101 is the IP the phone receives; somehow it does not respond to ping and is then deauthenticated for some reason.

    Anybody here have a clue what is going on and have any pointers on where to search for this? I am running the latest 2.0RC3, wireless card is a Linksys WMP54G with RaLink chipset. Nothing special running/installed/configured on the pfSense box at all. If you need any more info I will be more than happy to provide!


Log in to reply