Session-TimeOut still broken?



  • Hi, I'm testing captive portal with FreeRadius on 1.0.1-SNAPSHOT-03-08-2007 but Session-Timeout attribute doesn't work. Any plan on when this will be fixed? It is a showstopper for me and I don't wont to revert back to M0n0wall, PFsense is far superior.



  • We recently synced the CP code with m0n0wall again. Are you sure this feature works in m0n0 but not pfSense? if so, whech version of m0n0 are you testig with?



  • It used to work in m0n0, but I tested it several months ago, I'm going to retest and report back.



  • Tested on M0n0wall 1.23b4 and it works as expected, the user is logged out after Session-Timeout from radius server is reached.



  • Please test a recent snapshot.



  • I already tested with 1.0.1-SNAPSHOT-03-08-2007, is there a newer build? If yes please tell me from where I can download it cause from snapshots.pfsense.com the are no newer builds.



  • Yes, look at the file date and time.  The version is not bumped daily or hourly.



  • Tested with 1.0.1-SNAPSHOT-03-08-2007 (built on Wed Mar 14 16:11:27 EDT 2007) but Session-Timeout is still ignored. Even if it is set to zero the user can login successfully.



  • Sounds like the known m0n0 bug?



  • I also testing this feature. But currently have no time to check. Last time I saw there are option in captive portal to enable session timeout from radius reply. But it have been taken out coz that time the feature doesn't works. I think need to re-enable config option again so the this feature will enable. I will try to check the code again and hopefully can solve this problem.



  • @sullrich:

    Sounds like the known m0n0 bug?

    No, in M0n0 the user can still log out if Session-Timeout is set to zero (and I consider this a bug), but if Session-Timeout is set to 60 the user is automatically logged out after 60 seconds. In pfSense the user is not logged out after 60 seconds. Any ideas?



  • No idea, our code is 99% the same, I checked and re-sync'd a few weeks ago.



  • sullrich,

    Just testing out 1.2-Beta-1. It seems session-timeout is working if we enable it in captive portal config page. But the option was taken out last time when the session timeout is broke. In /etc/inc/captiveportal.inc (line 473) there is checking to disconnect the user based on session-timeout. The checking is

    isset($config['captiveportal']['radiussession_timeout'])

    I test it by include the option in config.xml by vi and it working. Hope to see the fixed.

    Thanks



  • Can you please provide a diff of your changes.



  • there is no change to the code. I just manually put

    <radiussession_timeout>1</radiussession_timeout>

    under <captiveportal>in /cf/conf/conf.xml.

    in m0n0wall there is a option (checkbox) in captive portal configuration. Not remember the exact word, but it something like 'use session_timeout returned by radius'. The checkbox option was taken out in pfsense last time coz the feature not working.

    hope this help..</captiveportal>


Log in to reply