Pf 2.0 RELEASE



  • Por si alguien no se entero….

    Para obtenerla:
    System-->Firmware-->Updater-settings

    Cambiar a:pfsense stable release updates (i386) o (amd64)



  • Imagino que es solo para los que tengan instalada una versión previa de la 2.0, ¿no?. Es decir, para los que tenemos la 1.2.3 no nos valdrá. ¿O sí?


  • Rebel Alliance

    Funciona sin problemas, pero antes de actualizar consulta la Guia, en documentación:

    http://doc.pfsense.org/index.php/Upgrade_Guide






  • Pues lo he actualizado y he tenido que volver a la 1.2.3 porque tras instalar la nueva versión sin errores, al arrancar me daba problemas con las tarjetas de red ("network interface mismatch"), y por mucho que hacía las asignaciones me volvía a saltar el error.

    He leído por ahí que a alguno le pasaba lo mismo y que era porque en el archivo config del firewall, tenía algún caracter internacional. He revisado el mío y he encontrado un "á" y un "ó", aunque están en la descripción de algunas reglas.¿Creeis que puede ser debido a eso?

    También he leído que a alguno le pasaba y lo achacaba a que tenía "Load Balancing" activado, pero el post es de hace casi un año y los de pfsense le decían que iban a solucionarlo, así que a a estas alturas no creo que sea ese el problema.


  • Rebel Alliance

    De la guia de actualizacion: http://doc.pfsense.org/index.php/Upgrade_Guide

    International/Special Characters in 1.2.x Configs
    International characters, such as åäö and so on, were not supported on 1.2.3, but were allowed in some places due to overly lenient input validation and less strict XML parsing. This causes invalid XML, and as such if you were lucky enough to not have 1.2.x crash and toss out the config on you with such characters, it will not upgrade to 2.0 cleanly.

    2.0 will reset and toss out the config on every reboot, leaving you at an "assign interfaces" prompt since it does not have a valid configuration.

    You can run your config through an xml parser like xmllint and it will show you where the problems are. Fix them, and the configuration can be upgraded. The good news is that these characters are handled properly in most areas of the 2.0 GUI, and they are CDATA escaped so they are safe from such errors.

    You can install the new Pre-2.0 Upgrade Check package (System > Packages, Available packages tab), and then go to Diagnostics > Pre-Upgrade Check. This package will check over your config.xml and alert you to potential issues.

    Instalas el paquete "Pre-2.0 Upgrade Check " y te aseguras de que todo esté correcto antes de actualizar



  • Perfecto, gracias. Lo probaré.

    Un saludo



  • Madre santa, no habia leido esta noticia, por fin ya lo etiquetaron como "Release", lo vengo actualizando desde hace meses en 3 firewalls que tengo y nunca tuve problemas con ninguno.

    Que buena onda  ;D ;D ;D ;D ;D ;D ;D ;D ;D ;D ;D



  • ya actualize el srv y todo funcionando muy bien..  ;D



  • y q  quiere decir release. ya es la definitiva.?.



  • He instalado el paquete pre-upgrade y efectivamente, daba fallo por la "ó" que había en una descripción. Lo he solucionado y ya estoy en la 2.0.

    Muchas gracias por la ayuda



  • hola  a todos.cual es el link para descargar el pfsense 2.0 release.Gracias.



  • @ANTONY:

    hola  a todos.cual es el link para descargar el pfsense 2.0 release.Gracias.

    muy facil en el blog. cuesta buscar un poco no  :-\

    http://blog.pfsense.org/?p=598


Log in to reply