NIC Intel 4 ports sur Dell Dimension E521 ?



  • Hello,

    Je suis un utilisateur d'IPcop et SME depuis 10 ans, je passe enfin à pfSense !
    Ca fait 5 mois que je dois m'y mettre, je prends enfin le temps aujourd'hui, je grave l'ISO de la RC3, l'installe et hop, je vois la sortie de la finale…  :-\

    J'ai besoin de plusieurs ports sur cette machine :
    3 WANs + éventuel futur 4e
    1 LAN
    1 DMZ

    Je viens donc d'installer la RC3 (je recommence demain avec la finale) dans un Dell Dimension E521 (AMD Athlon(tm) 64 Processor 3800+  + 4Go de RAM) et 4 NIC Gigabit.

    • 1 broadcom (intégrée)
    • 1 DLINK    PCI
    • 1 NetGear PCI
    • 1 TPLink  PCIe

    Elles sont toutes détectées.

    C'est la config de test. Pour la mise en prod, je dois avoir plus de ports, je vais donc investir dans une Intel Quad Port + ajout d'un NIC utilisée aujourd’hui + la NIC intégrée à la CM.

    Mais je ne sais quel modèle choisir :
    Gigabit ET Quad Port (PCIe)
    Gigabit ET2 Quad Port (PCIe)
    Pro/1000 PT Quad Port (PCIe)
    Pro/1000 GT Quad Port (PCI)
    Pro/1000 MT Quad Port (PCI)

    D'après le fichier de référence Intel, elles sont toutes supportées sous Linux et FreeBSD.
    La machine possède 2 slots PCI et 1 PCIe.

    Auriez-vous, svp, une idée, un conseil ?
    Je dois la commander au plus vite.

    d'avance, un grand merci.



  • J'ai plusieurs routeurs pfsense en production avec des cartes PRO/1000 et je n'ai jamais eu de problème avec.

    Le PCIe est préférable pour des questions de bande passante

    Donc : Intel PRO/1000 PT (attention elle est en PCIe 4x, ton Dell n'a pas ce port là, il faudra utiliser le PCIe 16x)



  • Merci ! :)

    Donc, récap.
    La Pro/1000 PT supporte le PCIe 4x - 8x - 16x
    Ma machine à 2 ports PCIe, un port 1x et un port 16x ( http://support.euro.dell.com/support/edocs/systems/dime521/en/SM_EN/specs.htm )
    Le port 16x est utilisé par la carte graphique.
    Je vais donc acheter une petite carte graphique en PCI (pour ne pas utiliser le PCIe 1x) pour la mettre ailleurs que sur ce port PCIe 16

    Encore merci ! :)

    Ah oui, j'y ai repensé sous la douche ( … ), j'ai oublié un port dédié au WiFi publique... donc il me faudra 7 ports au total !



  • Ca me fait donc 7 ports au total maxi dans cette config.

    Je vais donc prendre une Intel PCIe 1x un port, et une Intel Dual port en PCI (n'existe pas en PCIe 1x) pour avoir un 8e port par sécurité, donc il n'y a que la Intel Pro 1000 MT Dual Port si je ne me trompe pas.



  • Je viens de trouver une Intel Gigabit CT Desktop en PCIe 1 à 16x mais elle n'est pas compatible FreeBSD :'(
    http://www.intel.com/support/network/sb/cs-009221.htm
    Donc je garderai la TP-Link qui elle a été détectée pendant l'install de la RC3.

    Ca vous semble ok cette config ?



  • J'ai reçu la Intel Quad Ports pour la mettre sur le PCIe 16x de mon Dell, mais… au bout de 2 minutes, la machine freeze.
    J'ai à peine le temps d'attribuer toutes les interfaces et hop, bloqué.

    J'ai viré toutes les cartes réseaux, et c'est bien la quad port qui fait planter. Je les remets toutes sauf la quad port et aucun freeze.

    Génial, je suis coincé...



  • Donc récap, c'est une Pro/1000 PT Quad Port (PCIe) que j'ai commandé.

    Voici la carte mère du Dell E521 avec le port PCIe 16x en noir et avec le clips bleu :
    http://media.photobucket.com/image/recent/mnm-computers/45-2.jpg
    http://media.photobucket.com/image/recent/kang1290/RNJNSMobos002-Copy.jpg

    Et voici la Intel Pro/1000 PT, en PCIe 4x dixit la boite, et "Compatible with x4, x8, and x16 full-height and low-profile PCI Express* slots" dixit le site Intel.
    http://img5.cherchons.com/marchand/pmcdn.priceminister.com/photo/848074363.jpg
    http://i.ebayimg.com/t/NEW-Intel-PRO-1000-PT-Quad-Port-PCIe-NIC-EXPI9404PTLBLK-/00/$(KGrHqMOKj0E4CSwCqpWBOCmK4fQlw~~_12.JPG
    http://cd.ch-img.com/25071-intel-pro-1000-pt-quad-port-low-profil-oem,bWF4LTYwMHg2MDA=.jpg

    Le port de la carte est plus petit que le slot mais ça semble normal.

    pfSense détectait bien toutes les cartes (à base de realtek, broadcom, ou Intel, que ce soit la quad port ou la dual port), toutes les interfaces étaient vues et attribuées).

    Pour l'instant je ne trouve pas de piste sur le net, ni aucun prb avec pfSense 2.

    Ouinnn…



  • Une piste ?

    Dans ce topic : http://forum.pfsense.org/index.php?topic=40719.0

    Works like a charm:

    pfSense 2.0-RC1-amd64 (cdrom)

    Intel PRO/1000 PT Quad Port Server Adapter
    Chipset 82571GB

    J'ai utilisé l'iso "pfSense-2.0-RELEASE-i386.iso.gz"
    Je vais donc tenter avec le "pfSense-2.0-RELEASE-amd64.iso.gz"…



  • Pas de chance, même prb. Install terminé, reboot, je tente d'attribuer les interfaces, et au bout de 2m, l'affichage saute puis Freeze…



  • Que donne un boot sans ACPI ?



  • J'ai tenté, rien de mieux.

    J'ai ajouté ces infos sur le topic anglais.
    J'ai la même machine en spare, même bios pour les 2 (le dernier).
    J'ai échangé la machine, aucun prb. J'ai changé l'alim, la RAM, le HD, le CPU, etc.

    Puis, je me suis aperçu que ça freeze uniquement quand un des ports de la Intel PT Quad Port passe en Gb. Si je lui mets un lien 100Mbits, aucun freeze !

    Si je laisse le câble bindé en Gb, ça freeze pendant le boot :
    http://www.hebergeur-images.fr/images/929017493.jpg

    Si je laisse la machine booter et que je branche le câble une fois sur la console, après 2 minutes j'ai ça :
    http://www.hebergeur-images.fr/images/822566660.jpg

    Merci pour ton aide :)


Log in to reply