Problème de connexion PPTP au travers de pfsense v2



  • Bonsoir,
    Depuis l'installation de la V2, je ne parviens plus à me connecter à certains serveur PPTP. Ces derniers fonctionnent parfaitement. Si je me connecte directement sur le modem, je n'ai aucun souci.

    Sur pfsense, j'ai tout ouvert sur les ports WAN et LAN, histoire de faire un test. Et toujours l'impossibilité de me connecter.

    Je n'avais pas ce problème avec la 1.2.3

    Quand je regarde rapidement les logs, rien n'est bloqué :

    pass Sep 21 20:20:19 LAN 194.107.100.221:50940 xx.xx.xx.xx:1723 TCP:S
    pass Sep 21 20:20:20 WAN xx.xx.xx.xx 192.168.1.17 GRE
    pass Sep 21 20:20:20 LAN 194.107.100.221 xx.xx.xx.xx GRE

    Une idée ? Est-ce que j'aurai oublié un réglage ?

    Merci d'avance.



  • Avant d'avoir un début d'idée j'avoue ne pas avoir compris votre configuration.
    Puis une remarque : pptp est si peu sûr que son utilisation devrait être évitée a tout prix. Ce VPN est entaché de failles de conception majeures. RC4 est maintenant bien connu pour sa faiblesse sur le plan cryptographique.



  • Bonsoir,

    Je suis d'accord concernant pptp. Cela m'est imposé.

    Ma configuration est relativement. J'ai simplement installé pfsense derrière une livebox en tant que parefeu.

    Lorsque je me branche directement sur la livebox, je n'ai aucun problème pour me connecter en VPN sur les sites externes.

    Par contre si je me trouve derrière pfsense. Je n'y parviens plus malgré des règles où je laisse tout passer côté LAN et WAN.

    Internet –--Livebox (192.168.1.1) -----(WAN:192.168.1.17/24) Pfsense V2 (LAN:194.107.100.100/24) ----(192.168.100.221/24)PC

    Pour pfsense, j'ai les paramètres suivants :
    DNS : 192.168.1.1

    Interface WAN :
    ip 192.168.1.11/24
    Gateway : 192.168.1.1

    Interface LAN :
    ip 194.107.100.100

    Les postes
    IP : 194.107.100.0/24
    Gateway : 194.107.100.100
    DNS : 194.107.100.100



  • Voici le constat que je fais après quelques heures…
    J'ai réinstallé pfsense en ne paramétrant que les adresses ip des interfaces + DNS. J'ai défini manuellement un ip sur un poste.
    La connexion pptp fonctionne sans problème.

    J'ai ensuite paramétré le serveur DHCP pour l'interface LAN. Puis j'ai réservé une IP spéficique pour la quarantaine de postes du site sauf mon poste.

    A partir de ce moment là, je ne pouvais plus me connecter en PPTP sur les serveurs extérieurs.

    Avec d'autres tests, en mettant mon poste en ip fixe ou avec une ip réservée par le serveur DHCP je parviens à me connecter en VPN.

    Le constat : lorsqu'il y a, au niveau du DHCP, des adresses IP réservées, on ne peut se connecter qu'avec des postes dont l'ip est soit réservée au niveau du serveur dhcp soit avec une ip définie manuellement.

    Est-ce normale ?
    Suis-je le seul à avoir ce comportement ? .... peut être le seul à utiliser pptp  ;)



  • Cette page a-t-elle été lue : http://www.pfsense.org/index.php?option=com_content&task=view&id=40&Itemid
    (notamment les limitations de PPTP).

    Personnellement, je recommande de ne pas (plus) utiliser PPTP, comme ccnet.
    OpenVPN est un protocole bien supérieur : il n'y a pas de difficulté à avoir un serveur et faire du filtrage (en entrée), et avoir, en parallèle, plusieurs clients internes accédant à des serveurs externes (en sortie).



  • Bonjour,

    Je suis tout à fait d'accord. Certains sites que nous ne maitrisons pas nous imposent de nous connecter en pptp. Par contre chez nous, il n'y a pas de serveur pptp de paramétré sur pfsense.
    Le problème rencontré ne concerne que les clients internes qui ne parviennent pas à accéder aux serveurs pptp lorsqu'ils sont en dhcp.


Log in to reply