WebGUI & Apache Conflict [Solved]



  • Hello guys, I’m having a bit of a problem here that I need help with. I have a web server running with apache 2.2 behind my pfsense box. Apache defaults to port 80. I guess the webgui for pfsense does as well. This poses problems I believe.

    I want my pfsense webgui accessible from outside networks (internet), which was/is working fine on my default port that it runs on. Now I enable my apache server, & also had it running on port 80. So it was allowing me to access my pfsense webgui, but not my webpage. Now to solve this problem I was trying to leave apache on port 80 & change pfsense to port 8500. I went to the advanced settings & changed it to port 8500.

    Everything was working fine from my internal network, then I tried accessing it from outside computer (via internet) & typing just my domain name forwards me to my test “it’s working” apache page. However it completely kills the webgui access (when pfsense is set to port 8500). So, I remote desktop’d into my server & accessed webgui from internal network & turned off port 8500.

    Webgui goes back to working on public internet. So I thought maybe if changing webgui port it has to have a nat rule (port forward). Tried port forwarding port 8500 to 192.168.1.1 (pfsense box), however that still didn’t work.

    At a loss as to what would break webgui access through internet when changing the default webgui port? Any suggestions?



  • Disable redirect rule on same advanced options.
    And use pfsense gui with ssl.



  • The redirect rule sure, but you also have to adjust the firewall rule that normally blocks WebGUI access on the WAN interface so that it allows port 8500.



  • @marcelloc:

    Disable redirect rule on same advanced options.
    And use pfsense gui with ssl.

    This worked, Thanks!

    @podilarius:

    The redirect rule sure, but you also have to adjust the firewall rule that normally blocks WebGUI access on the WAN interface so that it allows port 8500.

    I originally created a NAT port forward rule to 192.168.1.1 (pfsense box) & that automatically made a firewall rule, but it still didn't work that way.

    From my internal network my server is on 192.168.3.2, i have to access the website via typing 192.168.3.2. I can't use my domain name to access my website from inside my network, i get a "connection is taking to long to respond" error. However i can access my pfsense box via https://mydomain.com, but not my website on the regular http side. Just find this weird. However from outside world http://mydomain.com does lead to my website & https redirects to my pfsense login.

    I did already configure NAT reflection, as I said I can access my pfsense box internally via my domain name, but not my server via domain name, but it doesn't really matter for internal use. As long as it works from the outside which it does.


Log in to reply