[Résolu]-[squid] - mise à jour ou suppression impossible



  • Bonjour,

    pfsense 1.2.3

    squid + squidGuard + squidlight

    Je n'arrive pas à mettre à jour mon package squid… et actuellement il ne veut plus se lancer...

    Quand je tente une maj du package, je reste bloqué sur :

    Removing package...
    Loading package configuration squid.xml...
    Loading package instructions...

    Et en bas de ma page php :

    Warning: main(squid.inc): failed to open stream: No such file or directory in /usr/local/pkg/lightsquid.inc on line 36 Fatal error: main(): Failed opening required 'squid.inc' (include_path='.:/etc/inc:/usr/local/www:/usr/local/captiveportal:/usr/local/pkg') in /usr/local/pkg/lightsquid.inc on line 36

    Même message quand je tente de supprimer le paquet...
    Même message quand je tente de supprimer/mettre à jour squidGuard ou lightsquid... Donc je tourne en boucle.
    Avez vous une piste ?

    SQUID : Current: 2.7.9_4.1 / Installed: 2.7.9_4
    SQUIDGUARD : Current: 1.4_3 pkg v.1.9 / Installed: 1.3-03
    LIGHTSQUID : Current: 1.7.1 pkg v.1.2 / Installed: 1.7.1

    Dans le menu de gauche, quand je clique sur Proxy Server, je mange ce message :

    Warning: main(/usr/local/pkg/squid.inc): failed to open stream: No such file or directory in /usr/local/www/pkg_edit.php on line 53 Fatal error: main(): Failed opening required '/usr/local/pkg/squid.inc' (include_path='.:/etc/inc:/usr/local/www:/usr/local/captiveportal:/usr/local/pkg') in /usr/local/www/pkg_edit.php on line 53

    Quand je clique sur Proxy Filter, je mange ce message :

    Warning: main(squid.inc): failed to open stream: No such file or directory in /usr/local/pkg/squidguard_configurator.inc on line 51 Fatal error: main(): Failed opening required 'squid.inc' (include_path='.:/etc/inc:/usr/local/www:/usr/local/captiveportal:/usr/local/pkg') in /usr/local/pkg/squidguard_configurator.inc on line 51

    Enfin, quand je clique sur Proxy Report, je mange ce message :

    Warning: main(squid.inc): failed to open stream: No such file or directory in /usr/local/pkg/lightsquid.inc on line 36 Fatal error: main(): Failed opening required 'squid.inc' (include_path='.:/etc/inc:/usr/local/www:/usr/local/captiveportal:/usr/local/pkg') in /usr/local/pkg/lightsquid.inc on line 36



  • Je réponds moi même à mon problème, la réponse était dans de vieux posts du fofo anglais.

    Il suffit de faire un

    fetch -o /usr/local/pkg/squid.inc http://www.pfsense.org/packages/config/squid/squid.inc

    pour récupérer le fichier et ensuite on peut relancer l'install de squid.
    Dans la foulée, les paquets dépendants s'installent/mettent à jour.

    Je chercherai mieux la prochaine fois  ;)


Log in to reply