Problem beim Anlegen eines Authentication Servers



  • Hallo,

    wir nutzen den PFSense Server an einer Schule.
    Um den Zugriff auf das Internet für Lehrer und Schüler einzustellen,
    wollte ich heute einen Authentication Server im User Manger einrichten, der
    auf die AD von userem Server 2008 R2 zugreift.

    Wenn ich jetzt im Usermanger unter "Servers" einen neuen Server anlege,
    wird der nach dem Klick auf "Safe" nicht in der Liste angezeigt und oben rechts,
    wo PDSense."unseredomain" steht erscheint folgende Meldung:

    Acknowledge All [DATE] [config.xml] pfsense is restoring the configuration….

    Der gleiche Fehler tritt hier bei mir an einer VMWare Maschine auf.

    Ich gebe Folgende Daten ein:

    Descriptive name:                "Beschreibung"
    Type:                                  LDAP
    Hostname:                            IP oder Name des Servers
    Port value                            389
    Transport:                            TCP - Standard
    Protocol version                      3
    Search..                                One Level
    Base DN                                domain.lokal oder dc=domain;dc=lokal
    Authen....                            ou=schüler;dc=domain;dc=lokal
    Initial...                                Microsoft AD

    Ein Klick auf Safe und... nichts in der Liste und wieder:
    Acknowledge All [DATE] [config.xml] pfsense is restoring the configuration….

    Habe ich da einen Denkfehler oder wo ist das Problem ?

    Gruß

    Manfred



  • Hallo,

    eventuell gibt es Probleme mit dem "ü"
    probiere es mal ohne "ü", ob er dann speichert.

    ansonsten könntest du das "ü" vielleicht durch folgendes ersetzen:

    ü
    Schüler
    
    


  • Ich habe ein ähnliches Problem bei der Authentifizierung meiner Benutzer.
    Solange meine Benutzer keinen Umlaut im Namen/Passwort verwenden funktioniert die Authenfizierung über die Server im User Manager einwandfrei.

    Meine Konfig:
    pfSense 2.0, Server 2008 R2 mit Active Directory eingerichtet als Authentication Server auf der pfSense

    @Manfred: Hast du schon eine Lösung gefunden?



  • Hat denn keiner einen Tipp :(



  • Hat denn jemand meinen Vorschlag, den ich 2 Posts weiter oben beschrieb, einmal ausprobiert ?



  • Im MS Active Directory kann ich keine Sonderzeichen wie & verwenden.

    Ich möchte die pfSense dazu bringen bei der VPN-Verbindung die Credentials an einen MS Network Policy Server (RADIUS) bzw. in der neuen Version direkt an meinem Primary Domain Controller weiterzuleiten.
    Das funktioniert ja auch wunderbar, bis auf den Spezialfall, wenn der Benutzer einen Umlaut im Namen hat. Da wird der Umlaut "verstümmelt" und die Authentifizierung schlägt fehl.

    Ich hab schon versucht die Localization von pfSense zu ändern bekomme das aber nicht hin.
    Irgendetwas habe ich bestimmt vergessen.

    Hat schon jemand seine pfSense auf einen deutschen Zeichensatz bzw. einen Zeichensatz mit Umlauten umgestellt?



  • Hallo,

    du hast Recht, meine "Idee" bezog sich darauf, dass Benutzer im User Manager der pfsense angelegt werden. Dort könnte man das Ganze probieren mit oben genannter Syntax.

    Aber in deinem Fall kann ich dir da leider nicht weiterhelfen.



  • Hallo,

    entschuldigt, dass ich mich erst jetzt wieder melde.
    ich war fast 3 Wochen krank.

    Also das mit dem Schüler in der OU funktioniert nicht.
    Ich habe mal die Gruppe Users mit cn=users;dc=dom;dc=lokal angegeben.
    Das funktioniert mit einem Testuser, aber auch nur mit Benutzer ohne Umlaute.

    Gruß
    Manfred


Locked