FTP Active mode bridging vsftpd



  • Hello all i'm having a problem successfully allowing incoming active ftp connections to a server located behind the firewall. The firewall is operating in bridged mode. I've tried every rule I can think of to allow ftp active mode to work along with enabling/disabling the ftp-helper on internal/external interfaces. I've read every message on the forum regarding ftp and have tried everything that seemed to make sense. I don't use NAT so i didn't deal with those configurations.  The only way I can get it to work is to disable the firewall rules altogether and allow all traffic to pass unfiltered.

    If I manually setup a rule to allow all incoming and outbound traffic that doesn't work either.

    FTP passive mode works just fine.

    I'm using vsftp and have configured it to allow active mode connections.
    I'm using the 1.01 release of pfsense



  • Please try the latest snapshot. There is more backend logic now to handle special situations like routed or brdged scenarios for the ftp-helper.



  • Well i have updated to the March 8 2007 snapshot but I experience the same behavior.



  • I've also tried with proftpd as opposed to vsftpd and windows server 2003 ftp and same behavior. i believe Windows FTP defaults to active mode


Log in to reply