Ayuda Configuración PfSense 2.0 RC3



  • Hola, soy nuevo en el manejo de PfSense ya eche un vistazo a los POST relacionados y no he podido dar con el error, les comento que tengo instalado pfsense 2.0 RC3 en un servidor el cual tiene 4 WAN's  y una LAN. Las WAN's llegan de 4 modems/router (Marca "Thompson" Model: TG585V7 proporcionados por el proveedor) los cuales tienen servidor DHCP y DNS. Al configurarlos dejo la opción de Type: DHCP para cada uno de las WAN's.

    En General Setup –> DNS Server tengo la opción seleccionada de  "Allow DNS server list to be overridden by DHCP/PPP on WAN" y las opciones de DNS Server por default (ninguno). ]En Advanced --> Miscellaneous en Load Balancing tengo seleccionadas las dos casillas "Use sticky connections" y "Allow default gateway switching". En Routing he agregado un nuevo grupo con las 4 WAN's en "TIER 1" y Trigger Level: Packet Loss.

    En firewall --> Rules--> Floating he agregado una nueva regla: Action: Pass. Interface: Selecciono las 4 WAN'S. Direction: Out. Source: Any. Destination: any. Destination Port: Any y en Gateway: Nombre de mi grupo en routing.
    En Firewall --> Rules --> Lan. Modifico la regla por default. Proto: any. Source: Lan Net. Port: *. Destination: *. Port: *. Gateway: Nombre de mi grupo en routing. Queue: None.

    Posteriormente en Firewall --> NAT --> OutBound: Manual Outbound NAT rule generation y agrego las 4 WAN's como sigue: Source: Any. Source Port: *. Destination: *. Destination Port: *. NAT address: *. NAT Port: *. Static Port: NO.

    Lo que me interesa es que haga el balanceo de cargas con round-robin entre las WAN'S pero solo logra salir por la WAN por default.  ???

    De Antemano Gracias y Saludos.


  • Rebel Alliance

    Las IPs que te entregan los Modems, son de distintos rangos ?

    Cada WAN utiliza un GW diferente ?

    La regla en "Floating" no hace falta

    Una regla en LAN es suficiente, para empezar, modifica el GW de la regla "Default allow LAN to any rule "  ( pones el grupo que creaste )

    La parte de "Outbound NAT" no hace falta modificarla, la puedes dejar en "Automatic outbound NAT rule generation" a menos que necesites alguna regla de NAT especifica, con el NAT en automatico, funciona sin problemas.

    Saludos



  • hola.
    una consulta….¿los modems/router Thompson estan en modo puente o modo router? eso es importante ya que si estan en modo router lo mas probable es que todos tengan la misma subred asignada 192.168.1.0/24 de preferencia tienes que ponerlos en modo puente para que a las WAN´s le entregue IP´s publicas.

    en caso de no poder interferir en la configuracion para dejarlo como puente, te recomiendo que cada modem/router lo configures en subredes distintas y sin DHCP

    ej:  modem/router 1 192.168.1.0/24
          modem/router 2 192.168.2.0/24
          modem/router 3 192.168.3.0/24
          modem/router 4 192.168.4.0/24

    saludos.



  • @nilton_wolf:

    hola.
    una consulta….¿los modems/router Thompson estan en modo puente o modo router? eso es importante ya que si estan en modo router lo mas probable es que todos tengan la misma subred asignada 192.168.1.0/24 de preferencia tienes que ponerlos en modo puente para que a las WAN´s le entregue IP´s publicas.

    en caso de no poder interferir en la configuracion para dejarlo como puente, te recomiendo que cada modem/router lo configures en subredes distintas y sin DHCP

    ej:  modem/router 1 192.168.1.0/24
          modem/router 2 192.168.2.0/24
          modem/router 3 192.168.3.0/24
          modem/router 4 192.168.4.0/24

    saludos.

    Si, los modem/router están con diferentes rangos. Así como muestras en el ejemplo.
    Cada una tiene su DHCP y no puedo cambiar esta opción porqué no tengo los privilegios en la institución. Gracias por responder.



  • @ptt:

    Las IPs que te entregan los Modems, son de distintos rangos ?

    Cada WAN utiliza un GW diferente ?

    La regla en "Floating" no hace falta

    Una regla en LAN es suficiente, para empezar, modifica el GW de la regla "Default allow LAN to any rule "  ( pones el grupo que creaste )

    La parte de "Outbound NAT" no hace falta modificarla, la puedes dejar en "Automatic outbound NAT rule generation" a menos que necesites alguna regla de NAT especifica, con el NAT en automatico, funciona sin problemas.

    Saludos

    Si, cada WAN tiene su diferente GW. Y si son entregadas en rangos distintos. He cambiado las opciones a como me explicas y sigue sin hacer el balanceo. Gracias por responder pronto.


Locked