Change port on Captive portal to 80? Locked down guest machines…

  • Hi!

    A little bit of en emergency here. Have newly installed pf2.0 at a Hotel. Everything was working just fine until now. A batch of guests have very locked down machines which are only allowed to talk on port 80! So they don't reach the portal.

    My idea was to move the default pfGUI to 81 and move the portal from port 8000 to 80. This possible?


  • Don't know the portal, but webgui port can be almost anything

  • Yeah. That one i figured out my self  :D. Moved it the first thing I did. Now resides on port 81.

    So does anyone know if it is possible to move Captive Portal to port 80?

  • Talking to myself. Hopefully it may help someone else in the same situation.

    I edit the following files:

    References to port 8000 was changed to 8080. Enabled Captive Portal and viola! I'm now redirected to "pfsense-ip":8080 and ends up in the Portal login page.

    /var/etc/lighty-CaptivePortal.conf was automatically update by the changes made to the above files.

    This was done one my own (home/work environment) installation of pfSense. Next test will be to move my own pfGUI to another port than 80 and then change the Portal port to 80. I'll be back on this one.

    If anyone here with deeper knowledge can fill in on the subject I'll be very glad. For example will my changes survive a reboot? Is there another way of doing this? Using a proxy in someway?


    I'm back. Changing the port to 80 was no success. Resulted in a redirect loop. Don't have the time right now to continue my experiment. But if somebody has more knowledge and wants to fill in, please do!


Log in to reply