Forward su server web interno (pfs 2)



  • Buon giorno.
    Premetto che non sono un esperto di informatica, firewall, ecc.
    Ho installato pfs 2 in alternativa al solito router per avere delle funzioanlità più avanzate e di controllo sul traffico wan - lan su una rete aziendale di circa 20 postazioni.
    Tra le 20 postazioni, sempre sulla stessa lan e quindi sulla stessa scheda di rete del "router" c'è il server che funge da mail server e da web server.
    Con gli opportuni forward il server mail funziona sia in entrata che in uscita.
    Quando cerco di contattare dell'esterno quini sulla porta wan) il server web mi appare inesorabilmente la richiesta di accettazione del certificato e la pagina di accesso di psf.
    Ho letto qualche post più avanti di un analogo problema che l'utente si è "autorisolto" ma io non ne riesco a vire a capo anche se apparentemente ho la sua stessa configurazione sul port forward.
    In più pasticciando qua e la, non so cosa ho combinato, ma adesso cercando di accedere dall'esterno al mio server mi appare sul browser un messaggio di errore relativo al rebinding che ho potuto eliminare spuntando la relativa opzione nel menu advanced.
    Qualcuno riesce ad aiutarmi ?
    PS inutile dire che col router "hardware" la cosa funzionava. Con pfs2 sembra che la porta 80 anche sulla wan sia di uso esclusivo per pfs2

    HELP !!



  • PROBLEMA RISOLTO … parzialmente ...
    Seguendo ligiamente le istruzioni il sistema funziona: dall'esterno accedo al mio server.
    Adesso il problema è l'accesso dall'interno.

    Cerco di spiegare meglio: (potrebbe essere anche non corretto ma sino ad ora col router hardware ha funzionato)
    Al nome mail.xxx.it è legato l'indirizzo ip statico della mia wan. Digitando da browser l'indirizzo mail.xxx.it si accede alla mia webmail. Stesso discosro per i client di posta.
    Nei client di posta elettronica, ai campi pop3 e smtp c'è analoga impostazione: mail.xxx.it Essendo notebook, quando sono all'esterno dell'azienda tutto funziona regolarmente, ma quando sono collegati alla rete interna (dhcp) l'accesso non funziona più.

    Cos'altro devo impostare ???



  • Ok mi pare di aver capito. Il tuo è un problema di DNS sostanzialmente, in questo caso l'IP mail.xxx.it da fuori funziona ma internamente all'azienda non può funzionare.
    C'è una soluzione molto facile, si chiama "split-horizon DNS", in pratica fa sì che Pfsense, a seconda della rete da cui proviene la richiesta, risponda con IP differenti.

    Per fare questo devi andare in "Services" -> "DNS forwarder". Non appena si apre il menù devi flaggare l'opzione "Enable DNS Forwarder". Più sotto invece vedrai che puoi inserire staticamente delle entry; Clicca sul "+" e nella pagina successiva nel campo host inserisci solamente "mail" e nel campo domain il resto, es. "miodominio.it". Nel campo IP invece gli assegni l'IP di quel server ma della sua rete lan, metti una descrizione e poi confermi.

    In linea di massima questo è sufficiente ma con il DHCP potrebbe essere necessario qualche altro aggiustamento. Fai prima questa prova e poi fammi sapere.
    Per vedere se funziona, dopo aver impostato la entry, fai un ping da un pc in lan su mail.xxxx.it e se funziona ti restituirà un IP della rete lan. Per sicurezza svuota la cache DNS del client prima di fare il ping, per farlo devi dare "ipconfig /flushdns" se sei in Windows, "dscacheutil -flushcache" per Mac OS X, "sudo /etc/init.d/nscd restart" per Linux (dipende dalla distro).


Log in to reply