Traffic graph causing logout of webGUI…



  • Hi,

    Having just introduced our first pfSense devices in production, I have stumbled upon a rather strange issue.

    When I want to access the traffic graphs I am logged out of the webGUI (returned to login screen). Trying again to see the graphs I get logged out again.
    I've instead added the graphs as a widget on the dashboard, where I have no problem seeing the WAN and LAN graphs but as soon as I expand the graph for the PFSYNC network I am once again logged out.
    I therefore speculate that the PFSYNC network is the cause of this, but am at somewhat of a loss of what causes it.

    We are running version 2.0-RELEASE for AMD64.

    Hope someone has a suggestion.

    Regards,
    Anders



  • Confirming - had same issue here. Fresh install of pfsense 2.0 on i386 (p4/Intel chipset) platform. But it seems browser-dependant, logs out pfsense when accessed via IE9 but not when accessed via Firefox 7 (Win7 client computer)



  • I'll give it a try with my Opera browser and see what happens :)



  • FWIW clean reinstall, new config, same result, browser dependent



  • @stilez:

    FWIW clean reinstall, new config, same result, browser dependent

    +1, same issue on IE9, have not tried any other browser however.



  • @pf2.0nyc:

    @stilez:

    FWIW clean reinstall, new config, same result, browser dependent

    +1, same issue on IE9, have not tried any other browser however.

    +1 IE9, haven't tried other browsers



  • Same here, on IE8, IE9 and Firefox.

    PFS 2.0 AMD64


  • Rebel Alliance Developer Netgate

    Moral of the story, as always, don't use IE*. :-)

    • If you want to use IE, patches fixing HTML/CSS/other issues are always accepted.


  • In case anyone finds this thread when searching for SVG and IE9 problems, several people have now confirmed that they have an issue with the SVG support in IE9.
    The current workaround is to apply one's morals to the choice of a browser and or to work on a patch.  ;D



  • @greybeard:

    In case anyone finds this thread when searching for SVG and IE9 problems

    It's more that it appears to cause an unexpected logout on the router.



  • @jimp:

    Moral of the story, as always, don't use IE*. :-)

    • If you want to use IE, patches fixing HTML/CSS/other issues are always accepted.

    Why do I get the feeling you don't like IE? ;) :P

    But if it's a general issue with IE, why does it only happen on the PFSYNC network and none of the others?


  • Rebel Alliance Developer Netgate

    Hard to say why, but if it doesn't happen in any other browser, it's still IE's interpretation of the code to blame.

    If someone who knows IE and wants to debug it in more detail, we'd be happy to take in patches for that.



  • On a clean install of pfSense 2.0-RELEASE amd64, the Traffic Graph page destroys the session as the SVG is loaded by IE9. The graph.php page/template renders, then the SVG (or javascript?) kills it. There is no issue with the dashboard traffic graph widget.

    IE8 with no SVG plugin displays the page and an informative table - no logout.


Log in to reply