PfSense 2.0 + Hyper-V



  • Доброго времени суток!
    Столкнулся с проблемкой, никак не могу понять откуда растут ноги.
    Сценарий №1
    Чистая установка 2.0.
    Добавляем интерфейсы de0 - Wan, de1 - Lan (Static 10.10.1.99)
    ping 10.10.1.99
    Ответ от 10.10.1.150: Заданный узел недоступен.
    При чем во время загрузки проскакивает 2 пинга и затык, если успеть приостановить загрузку после того как поднялся webConfigurator (то биш вебморда), то все ОК, Wan поднимается инет вижу, пинги до Lan проходят.
    Сценарий №2
    Обновление одного 1.2.3.(ничего лишнего прозрачный прокси) из прокси до 2.0. Все хорошо никаких проблем
    Сценарий №3
    Обновление второго 1.2.3 (настроен Captive (MAC filter, прозрачный прокси), PPTP) до 2.0.
    Те же проблемы что и в случае сценария №1
    Итог:
    1. Не могу попасть на вебморду (ну почти см. выше, если не изгалятся то не могу)
    2. Почему то нет ответа от Lan
    В общем выручайте товарисчи. Зарание спасибо.
    Настройки Hyper-V
    Устаревший сетевой адаптер.



  • а что трудно с машины де стоит ПФ проверить почему пинги не идут ?
    Syslog проверь.
    а вообще tcpdump в помощь



  • Проверь режимы сетевух в Hyper-V. Возможно стоит выставить их в bridge с реальной. У меня лично так работают и проблем не видят



  • а что трудно с машины де стоит ПФ проверить почему пинги не идут ?

    В том то и дело что ничего не мешает. Дошло до того что выключил нафиг файрволл
    Потом нашел темку http://forum.pfsense.org/index.php/topic,42214.0.html
    в Syslog Наткнулся только на это
    Oct 24 20:48:19 apinger: Starting Alarm Pinger, apinger(23785)
    Oct 24 20:48:19 apinger: No usable targets found, exiting
    Oct 24 20:48:21 dhcpleases: Could not deliver signal HUP to process because its pidfile does not exist, No such file or directory.
    Oct 24 20:48:21 check_reload_status: Updating all dyndns
    Oct 24 20:48:21 dhcpleases: Could not deliver signal HUP to process because its pidfile does not exist, No such file or directory.
    больше ошибок нет.
    Еще ругался на RRD переустановил проблем нет.
    Что с TCPdump делать?



  • @goliy:

    Проверь режимы сетевух в Hyper-V. Возможно стоит выставить их в bridge с реальной. У меня лично так работают и проблем не видят

    Бридж не могу всего 2 сетевых реально.



  • Пока помогает только пинг во вне.
    Upd: включил обратно Captive, теперь не помогает даже пинг



  • @tjsolomon:

    Бридж не могу всего 2 сетевых реально.

    И что? у меня одна реальная, сижу с неё, и на virtualbox'e еще 3 бриджовые виртуальные, норм работают. На виртуалке пфсенс 2.0, тестирую динамический ВАН _)



  • @goliy:

    @tjsolomon:

    Бридж не могу всего 2 сетевых реально.

    И что? у меня одна реальная, сижу с неё, и на virtualbox'e еще 3 бриджовые виртуальные, норм работают. На виртуалке пфсенс 2.0, тестирую динамический ВАН _)

    Вместе с проксями сидит еще одна виртуалка.
    НО забавность данного случая сводится еще и к тому что вторая прокся обновилась, и ничего не делал что бы ее подшаманить



  • Если с bridge'ом не работает, потом проверь обновления. посмотри что не так с dhcp-serverом, отключи apinger.



  • @goliy:

    Если с bridge'ом не работает, потом проверь обновления. посмотри что не так с dhcp-serverом, отключи apinger.

    Поставил прямой бридж только для одной виртуалки, остальные опустил результат такой же
    DHCP сервер выключен, в сети Мелкомягкий сервер дхцп
    Как отключить Апингер не нашел?



  • может натолкнет на какие то идеи- у меня в вмвраре, в некоторых случаях при использовании бриджей приходилось включать на вмварных свитчах Promiscuous mode



  • Есть еще мысли?



  • мдя проблемка имеет место быть решение пока предлагают только такое

    ifconfig de1 down
    ifconfig de0 down
    ifconfig de0 up
    ifconfig de1 up
    dhclient de0 (если есть дхцп)
    

    сохранить в файл /usr/local/etc/rc.d/startup.sh



  • Еще один вариант который только что опробовал ставим пакет
    Shellcmd
    В него вбиваем комманды




  • Если проблема актуальна, попробуйте указать мас для сетевух.



  • @i.a.m.:

    Если проблема актуальна, попробуйте указать мас для сетевух.

    Подробнее пожалуйста:
    1. Ввести Mac в настройки лан и ван?
    2. Указать статические Маки в виртуальных сетевых??



  • @tjsolomon:

    @i.a.m.:

    Если проблема актуальна, попробуйте указать мас для сетевух.

    Подробнее пожалуйста:
    1. Ввести Mac в настройки лан и ван?
    2. Указать статические Маки в виртуальных сетевых??

    мы одно время использовали связку hyper-v и freebsd, сети так же не было по не пинганешь из нутри. Вроде бы решили указанием статических маков для виртуальной сетевой в настройках hyper-v.



  • @i.a.m.:

    @tjsolomon:

    @i.a.m.:

    Если проблема актуальна, попробуйте указать мас для сетевух.

    Подробнее пожалуйста:
    1. Ввести Mac в настройки лан и ван?
    2. Указать статические Маки в виртуальных сетевых??

    мы одно время использовали связку hyper-v и freebsd, сети так же не было по не пинганешь из нутри. Вроде бы решили указанием статических маков для виртуальной сетевой в настройках hyper-v.

    Ясно, но как это помогает? Учитывая что фряхе вообще без различно используется или нет мак адрес



  • @tjsolomon:

    мдя проблемка имеет место быть решение пока предлагают только такое

    ifconfig de1 down
    ifconfig de0 down
    ifconfig de0 up
    ifconfig de1 up
    dhclient de0 (если есть дхцп)
    

    сохранить в файл /usr/local/etc/rc.d/startup.sh

    Проблема один в один. на  3-х серверах Hyper-V . И имено такое же решение, не понятно почему но только после того как сетевушки передернуть (down & up), все начинает работать. У тебя скорее всего тоже самое. У знакомых такие же проблемы были, решали так же .


Locked