No se visualiza correctamente Facebook



  • Buen dia comunidad!

    Vengo con un problema que me tiene acongojado:

    En mi trabajo me pidieron un servidor para administrar el Internet y poner Firewall, sin dudarlo propuse el pfSense y funciona de maravilla! El problema es que lo unico que no quieren que bloquie es el face book.

    Tengo el pfSense v2.RC.3 con el Squid instalado. Tambien le instalé el LightSquid para los reportes de navegación y el Bandwidth.

    El Facebook me lo visualiza así:

    A menos que le escriba la dirección así: https://www.facebook.com así, SI lo abre bien, sin ningún problema. Pero no puedo estar en cada equipo para que las personas tecleen con https para ingresar al facebook. Ojalá me puedan ayudar por que ya busque la manerra por reglas en el Firewall como en configuración de la cache del squid.

    Muchas gracias por su atención!  ;)



  • Si no me equivoco, es porque las imagenes de facebook no siempre estan bajo el mismo dominio facebook.com… en las propiedades de las imagenes se puede ver el dominio que tendrias que liberar...

    Saludos,



  • JA! Tu preocupado por que no lo ves bien? Yo me preocupo porque no lo puedo bloquear por HTTPS.
    Actualiza a la version final de pfsense, a mi me soluciono muchos problemas

    Saludos



  • Como te han dicho, estás filtrando cosas que no deben estar en facebook.com

    Seguramente hojas de estilo CSS de facebook.net

    Usa Firefox con el complemento Live HTTP headers y podrás ver las peticiones que hace el navegador.

    O en la consola de pfSense un tail -f del log access.log de squid…

    Saludos,

    Josep Pujadas



  • Yo manejo squid con ACL, cuando algo que debe cruzar sin problemas y los tiene, no hay nada mejor que el log de squid, abre tu sesion via consola no hay de otra o bien usa el anyterm via web.

    Para mi, no hay nadie mejor que el mismo squid para decirte que te esta bloqueando, aprende a leer el log es una arma preciosa para estos problemas!!!



  • @djfenixchile:

    JA! Tu preocupado por que no lo ves bien? Yo me preocupo porque no lo puedo bloquear por HTTPS.
    Actualiza a la version final de pfsense, a mi me soluciono muchos problemas

    Saludos

    Hola djfenixchile,

    Bueno, a mí también me pasó lo mismo, no podía bloquear los dominios por HTTPS, porque squid sólo soporta el http en modo transparente.
    La solución consiste en cambiar squid a modo no transparente, y exigir que los clientes cambien los parámetros proxy desde sus navegadores.
    Luego, hay que bloquear el puerto 80 en las reglas del cortafuegos (LAN) así todo tiene que pasar a traves de squid ;)
    Si trabajas en un entorno Windows con Active Directory, puedes hacer una GPO para cambiar los parámetros proxy para todo el mundo, puedes también impedir a que los clientes modifiquen estas valores. Si estás interesado, puedo ayudarte aún mejor :)

    saludos



  • Muchas gracias a phill y a bellera (a este señor, me pongo de pie, gracias por sus tutoriales!!!), tenian razón, habia varios host secundarios a Facebook que no permitían la navegación correcta. Ya se resolvió el problema… y justo 3 dias después de resolverlo, me piden que lo bloquie junto a todas las redes sociales y Youtube  :-[ , ¡que se le va a hacer cuando tienes jefes tan indecisos!

    Lo que rescato de esto es que ahora ya se que pasa si me vuelve a suceder un caso similar. Les agradezco a todos su enorme ayuda!


Log in to reply