WebGui "System" menu mis-functioning on Firefox2/OSX



  • Hi,

    I've got:

    
    1.0.1-SNAPSHOT-03-23-2007
    built on Fri Mar 23 14:37:53 EDT 2007
    Platform
    
    

    installed on a Soekris Net4801.

    When browsing to the pfsense WebGUI, the System menu – and ONLY that menu -- and its pulldown don't function correctly.

    Here's the menu on hover over 'System' menu item:

    Moving the cursor down a couple of pixels, as if to select one of those menu items results in:

    Notice the blank space at the top of the menu, and the different menu items.  Any one of these menu items can be successfully selected.

    This behavior seems to ONLY happen on FireFox2/OSX.  When using Safari/OSX & FireFox2/OpenSuse, the menu functions normally.



  • Try pushing Ctrl + 0 and see if the problem persists.



  • Hi,

    @sullrich:

    Try pushing Ctrl + 0 and see if the problem persists.

    Assuming you intend a "page reload" ? (there's no Ctrl - O function in FF2/OSX), yes, the problem persists.

    Clearing local cache/session data also makes no difference.  Neither does quitting/restarting FF2.  Fyi, this occurs only in the default "nervecenter" theme.  "pfsense-pulldown" works fine.



  • FF 2.0.0.3 under OSX 10.4.9 and no issues. I bet you have changed your fontsize to non standard and this breaks themes. We always test with FF and it actually should be the best supported browser when it comes to pfSense (as the devs are mainly using it on Windows and OSX) though we test with other browsers as well.



  • View -> Text size -> Normal



  • View -> Text Size -> Normal makes no difference.

    Given the mention of font size, I checked & set FF2's "minimum font size" to "NONE" ( it was at "14" – I have a 1600 x 1200 screen rez, and tired old eyes)

    That seems to fix the issue.  Rather odd that 'it' manifests itself only on the one menu ...

    Any chance that that can be 'fixed' -- not that it's really broken -- ?  Without minimum font size capability -- which in FF2 applies to ALL pages/sites -- the screen font is intolerably small (for me; maybe others?).

    Thanks again.



  • OSX has a zoom feature (default ctrl and scrollwheel)  ;)
    I don't think we can fix that easily. Only option would probably be releasing a "big font" version of the theme for high resolutions so you can switch to it in the webgui.



  • @hoba:

    I don't think we can fix that easily. Only option would probably be releasing a "big font" version of the theme for high resolutions so you can switch to it in the webgui.

    Well, as I clearly don't know what the issue is, I'll simply use a different theme.  Really makes no difference to me. :-)

    Still, strange that only that MenuItem, and only in pfSense's GUI (as opposed to a slew of other php-based sites i use/visit), do I see that problem. Ah well, quirks.

    Thanks for checking.



  • I have the same issue - tired eyes and a minimum font size set to 14.

    As a result I've been using 'pfsense' as my theme for a year or so.



  • I saw the same thing yesterday with IE7.  Switching back to Firefox resulted in the menus behaving again.


Log in to reply