Virtualized pfsense unable to utilize full speed of internet connection?



  • I've been running pfSense 1.2 under vmware server 2.0 for quite some time with no issues. I recently upgraded my internet connection to 30/5. I also upgraded to pfSense 2.0. For a while I couldn't get past 10 mb download, but I finally realized that had to do with the network card I had configured for WAN. Once that was replaced with a 10/100 card, my speed increased. BUT, I can't seem to get past 20 mb. Utilizing the same hardware under Windows (turning off the vm and having windows directly connect to the cable modem) I can get 30 mb down. I don't have any issues maxing out my upload. I do not have traffic shaping enabled. Processor utilization according to pfSense is usually under 10% and memory usage around 15%. Does anyone have any other ideas?



  • I did not make any network benchmark in VMs but I guess bridged interfaces should bring best results in this matter, have you tried playing with different interface modes ? Another thing, did you try downloading from inside de VM or from a machine behind the VM ?



  • Both interfaces are bridged. The LAN interface is bridged with the network interface of the windows machine. The WAN interface is disabled in Windows and configured solely for use in pfSense. I've run speedtest on a laptop behind the firewall and not gotten the full speed of my connection. When I connect that same laptop directly to my cable modem and run the same speed test, I get the full speed. So it has something to do with my internal network, I'm guessing the firewall.

    What other interface modes do you suggest?



  • Bridged should be fine, you may try doing the same download from inside the VM, so you can narrow down the problem



  • Inside of pfSense? I just browse to speedtest.net and run that from a browser on my Windows laptop. Can I run some sort of similar test from pfSense?



  • I would try downloading a large file from a good known link, you can use wget to do so, but you must install it first from a shell, here I did this:

    pkg_add -r ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-8-stable/Latest/wget.tbz
    


  • Another thing you can try, you may change the LAN bridged interface to use a loopback adapter instead a network card, if I understood your problem well, It should be something like the one described here:
    http://timita.org/wordpress/2011/07/29/protect-your-windows-laptop-with-pfsense-and-virtualbox-part-1-preamble/

    take a look at page 5  ;)


Log in to reply