Openvpn et rien ….



  • Bonjour à tous,

    J'ai mis en place un openvpn sur mon pfsense 2.0, mais je n'arrive pas à joindre mon réseau interne.

    J'ai choisi comme adresse réseau du tunnel  10.0.8.0/22 et activé le "Redirect Gateway". Mon lan interne est en 10.0.0.0/22.
    J'ai rajouté dans les options la ligne suivante "route 10.0.0.0 255.255.252.0".

    N'arrivant pas du tout à joindre mon lan, j'ai même ajouté dans le fichier opvpn la ligne "push "redirect-gateway 10.0.0.1 255.255.252.0".

    Je pense que je suis en train de m'emmêler les crayons de plus en plus. Parce que j'arrive à monter le vpn, puisque le serveur m'attribue l'ip 10.0.8.1/255.255.252.0 avec comme passerelle 10.0.8.2 …..

    Je me noie mais je ne vois pas ou ...

    Merci pour un retour .



  • Tu veux faire du roadwarrior ou du P2P ?
    Normalement, tu n'as pas besoin d'ajouter de configuration spéciale sur le serveur.



  • Essayes l'extension "OpenVPN Client Export Utility" disponible dans les packages.

    Dans server :

    Server Mode : Remote Access SSL/TSL
    Protocol : UDP
    Device mode : tun
    Interface : Wan (selon ta config)
    Local port : 1194

    –-
    Crées des certificats

    DH Parameters lenght : 2014
    Encryption algo : AES-128-CBC


    Tunnel network : 10.0.60.0/24 (ou autre)
    Redirect Gateway : désactivé
    Local Network : 10.0.0.0/24 (selon ta config)
    Compression : activé

    --
    Dynamic IP : activé
    Address Pool : activé
    DNS domain : selon ta config (mondomain.local)
    DNS server : activé + à fournir

    Et c'est tout !!!


Log in to reply