COD MW3 Nat Type Strict



  • Hi,

    I can't seem to get NAT Type Open in MW3. uPnP is enabled and uPnP status says that that UDP3074 is forwarded to my computer, but no go:

    3074 keep state		udp 	(this PC's IP)	 	DemonwarePortMapping
    

    I've pretty much isolated the issue to the firewall, or at least some MW3->firewall combo, since I tested with a Cisco/LinkSys modem/router (also tried with just the router part connected to my regular modem) and then I got NAT Type Open. Cisco/linksys logs say:

    Mon, 2011-11-28 20:10:25 - Returning UPnPError 714: NoSuchEntryInArray
    Mon, 2011-11-28 20:10:25 - AddPortMapping: external NULL:3074 to (this PC's IP):3074 protocol UDP for: DemonwarePortMapping with timeout:0
    Mon, 2011-11-28 20:10:25 - no permission rule matched : accept by default (n_perms=0)
    Mon, 2011-11-28 20:10:25 - redirecting port 3074 to (this PC's IP):3074 protocol UDP for: DemonwarePortMapping
    Mon, 2011-11-28 20:10:25 - creating pass rule to (this PC's IP):3074 protocol UDP for: DemonwarePortMapping 
    
    

    The strange bit is that MW2 works, along with "everything else" that uses uPnP.

    Please help me out here, I'm running out of hope…

    Thanks,
    Floddy



  • I am having the same issues. I even setup a NAT rule for the required ports to my PC (as per a post on the IW forums) and still had strict NAT. However MW3 isn't the only issue, Tom Clancy's HAWX gives me the same issues and I haven't been able to pinpoint that, however all my other uPNP games work just fine.



  • Try this, it work for me
    http://forum.pfsense.org/index.php/topic,6042.0.html
    with UPnP Enable

    Vbob



  • @vbobmac:

    Try this, it work for me
    http://forum.pfsense.org/index.php/topic,6042.0.html
    with UPnP Enable

    Vbob

    This my friend worked perfect for me, MW3 is now reporting NAT as Open!!
    Thanks you have made the kids happy little campers now :)



  • @vbobmac:

    Try this, it work for me
    http://forum.pfsense.org/index.php/topic,6042.0.html
    with UPnP Enable

    Vbob

    OH HAPPY DAY!  :) :) :)

    Thank you SO much, NAT type is now "open"!

    However, instead of doing as described in the docs, I added a new rule which applies to the specific port that MW3 uses.



  • hmm can somebody help me out?

    i have configured 3 rules

    tcp/udp on port 3074
    tcp on port 27014 to 27050
    udp on port 27014 to 27030

    and activatet stati-port on NAT-Outbound in the mapping with the description "Auto created rule for LAN to WAN "

    are these steps correct???
    still geting Nat-Type > middle



  • beta,

    I saw the same thing too.  I had strict NAT, did the suggested change to make it static, that took me to moderate.  I did a reboot via web gui, still stuck at moderate.  I did a halt, and then cold reboot of pfsense, and that took it from moderate to open.  Apparently a reboot (via gui) doesn't do the same thing as a halt/ cold restart?

    Anyways, it's working, and I'm happy…



  • Good info, fixed my MW3 Thanks! ;D


Locked