[RESOLU] Problème redirection portail captif



  • Bonjour à tous,

    Je poste aujourd'hui un nouveau topic car je n'arrive pas à comprendre pourquoi mon portail captif ne me permet pas d'accéder au net.

    Je m'explique:

    J'ai pour projet de mettre en oeuvre un portail captif avec authentification par serveur radius (IAS sous windows serveur 2003)

    J'ai donc paramétré mon Pfsense ainsi que mon serveur radius. Lorsque j'ouvre une page web, j'arrive bien sur la page du portail captif. Je rentre mes identifiants et le serveur radius fais correctement son travail, je vois bien les trames access-request et access-accept sur Wireshark, installé sur windows serveur 2003. Cependant une fois l'authentification faite je n'arrive pas à accéder à internet, le navigateur web m'affiche le message si bien connu :" Le délai d'attente est dépassé "

    Voici un petit schéma de mon infrastructure:

    Vous voila maintenant au courant de mon petit problème, j'espère que vous saurez m'aider, en attendant je continue à chercher de mon côté en gardant un oeil sur le forum ;)
    N'hésitez pas à me poser des questions.

    Cordialement,

    Yannick.



  • Salut,

    intéerssant comme projet ;)

    Pour ma part j'opterai à première vue pour un problème de DNS.

    Ton firewall à tous les ports d'ouvert?
    Si depuis ta machine "finale" tu fais un nslookup, ça donne quoi?



  • Salut geronimoo, merci pour ta réponse et pour l'intérêt que tu portes à mon sujet.

    Mon maitre de stage te rejoint pour le problème de DNS, cependant il ne pas pas m'aider car il ne connait pas spécialement PfSense.

    Pour le nslookup depuis la machine finale (client) voici le screen que j'ai réalisé:

    Et voici le nslookup réalisé depuis le serveur Radius:

    Einstein étant mon serveur Radius et Pfsense ma machine Pfsense où est le portail captif.

    Pour ce qui est de l'ouverture des ports, je n'utilise pas Pfsense comme portail captif, ma question sera donc: Comment savoir quels ports sont ouvert ou fermé ??
    J'ai cependant réalisé 2 autres screens sur les règles de firewall de Pfsense, sur l'interface WAN et LAN.
    WAN:

    LAN:

    Voilà ce que je peux te répondre pour le moment, n'hésite pas à me demander d'autres informations. J'ai vraiment besoin que ce projet fonctionne correctement ^^
    Merci encore :)

    Yannick.



  • Le DNS est nécessairement utilisé pour tout accès Internet : on écrit http://www.google.fr/ et pas http://209.85.148.103/ ! (vous pouvez vérifier)

    Etre sûr du DNS du poste de travail est une nécessité et n'a pas de rapport avec pfSense !

    Je sous entend que le DNS des micros internes est soit pfSense soit un serveur interne (p.e. le Windows 2003) !



  • Salut jdh, merci de venir à mon secours!!

    J'ai bien compris le principe du DNS, convertir un nom en adresse IP et inversement. Lors de ma configuration j'ai activé le DNS forwarder de PfSense qui lui permet de faire suivre les requêtes DNS sur mon serveur windows 2003 (Contrôleur de domaine + DNS + IAS). Mon serveur DNS fait appel à ses redirecteurs pour contacter les autres DNS présent sur le réseau du lycée.

    J'ai enfin réalisé un nouveau nslookup de google.fr depuis un poste client qui donne ceci:

    Merci de ton aide, si tu as d'autres questions ou remarques je suis preneur ;)

    Yannick.



  • tu as manifestement un problème de DNS.

    Un problème tout bête, tente d'accéder à google.fr avec l'ip de ce dernier depuis ton navigateur internet.

    Autre chose tente de changer tes rules sous ton pfsense, car j'ai un doute vu que tu passes pas un radius, t"es peut être pas authentifié comme venant du "Lan Net". Change ta règle par 'any' pour tout ouvrir temporairement



  • Alors, je viens d'essayer de me connecter à google.fr directement via l'adresse IP 74.125.39.106 et le problème ne change pas, le navigateur web m'affiche toujours le même message d'erreur :"Le délai d'attente est dépassé"

    J'ai par la suite suivi ton conseil, j'ai changé les règles de PfSense, j'ai modifier de cette façon:

    Ce qui me donne au niveau du récapitulatif des règles:

    Après avoir appliqué ces modifications rien ne change :( Es-ce que les modifications que j'ai apporté au niveau des règles du firewall sont correcte ?

    J'ai réalisé des screens de toutes l'installation et des modifications que j'ai apporté à PfSense, si il est possible que ça puisse m'aider, je peux toujours les mettre en ligne sur le forum…



  • Bon, une nouvelle journée qui commence et toujours pas d'avancement dans mon projet.

    Faisons un peu le point.

    Nous avons d'installé:
    1 machine windows serveur 2003 avec contrôleur de domaine, DNS et IAS
    1 machine pfsense avec 2 interfaces. Une interface connecté à un point d'accès Linksys et l'autre à la machine WS2003

    Ce qui marche:
    L'affichage du portail captif au lancement du fenêtre de navigateur Web ==> OK
    L'authentification des utilisateurs sur WS2003 + Radius ==> OK

    Ce qui ne marche pas:
    La "redirection" vers la page d'accueil de l'utilisateur, grossomodo internet ==> PAS OK

    Les questions que je me pose:
    Puisse que l'authentification et l'affichage du portail captif se font correctement, comment se fait-il que je n'ai pas d'accès à internet ??

    Existe-t-il une forme de routage entre les 2 interfaces de pfsense ?
    Lors d'un fonctionnement normal, es-ce que les trames réseaux passent pas WS2003? (par rapport à mon architecture)
    Est-il possible que l'interface WAN de pfsense bloque le protocole HTTP ???



  • YOUUUHOUUUU !!! Pour ma part j'ai réussi :D

    Erreur stupide, voir même de débutant, je n'avais pas renseigné la bonne passerelle par défaut dans la zone de paramétrage de l'interface WAN.
    J'avais stupidement rentré l'adresse de mon serveur Radius :s

    Donc merci à tous ceux qui m'ont aidé et on essayé de trouver une solution à mon problème.

    Yannick.


Log in to reply