Error inexplicable al iniciar firewall pfSense



  • Buen día  a tos,

    Estoy reinstalando mi firewall pero nunca termina de arrancar se queda como pasmado, los detalles son:

    1.- Ya tenia instalado y funcionando sin problema por medio año aprox en este equipo.
    2.- Hubo una falla de luz y se desconfiguro hasta pienso que pudo dañar el disco duro porque al iniciar mandaba muchos errores al investigar en google me decía que era error de compatibilidad y decidí cambiar el HD.
    3.- Desde que le cambie el HD, termina la instalación correctamente pero nunca carga todo si alcaso pasa el primer menu y se queda bloqueado en el siguiente, adjunto imagen de donde se queda bloqueado.
    4.- Pense que podria ser la version ya que la ultima no tiene la opcion de un solo procesador(mi pc tiene una mother intel con un PIV) pero ya descargue la version 2.0RC1 y nada hace lo mismo.
    4.- Ya cambie el HD en marcas, samsung, segate, maxtor y hace lo mismo con todos, lo curioso es que también cambie en otro cpu con una placa Asus y hace lo mismo, también cambie el cable del bus, ya no se que mas hacer.

    Podrían decirme si tiene solución!, la verdad es que ya urge y solo pude iniciarlo con la distro de ipcop con esta no genera ningún error, pero en lo particular prefiero pfSense.



  • pienso que pudo dañar el disco duro porque al iniciar mandaba muchos errores al investigar en google me decía que era error de compatibilidad y decidí cambiar el HD.

    Igual tu problema es la controladora de disco… ¿Puedes postear los errores que te daba ANTES de cambiar el disco?

    Incluso podría ser la memoria RAM o la fuente de alimentación. Llevo con FreeBSD desde el 2000 y las averías que he visto originando problemas de disco eran debidas: al disco, a la memoria RAM o a la fuente de alimentación. Cualquiera de estas tres cosas puede originar errores de disco.

    Hazte un lápiz USB Parted Magic con http://unetbootin.sourceforge.net/

    Arranca con él y prueba la salud de tu disco con las smartmontools…



  • Ya le cambie la memoria RAM, Fuente de Poder y hasta un HD Nuevo sata e IDE y sigue con el mismo problema, instala sin ningun error pero a la hora de arrancar de pasa de la pnatalla que adjunte!

    Cabe mencionar que si estuvo trabajando prefectamente por 6 meses con todo el hardware que tiene y describo:
    1.- Mother Intel D865PERL
    2.- Micro PIV 3.0
    3.- RAM kingston una de 512mb y otra de 256mb con bus de 400mhz
    4.- Fuente de poder de 400watts
    5.- HD Maxtor 80GB

    Hasta que hubo la falla de luz empeso con este problema, el error que mandaba al iniciar es el siguiente:
    ad2: WARNING - READ_DMA UDMA ICRC error (retrying request)
    ***Welcome to pfSense 2.0-Release-pfSense (i386) on pfSense

    Lo que pude investigar de este error es relacionado al HD por eso lo he cambiado en las marcas Segate, Maxtor, Samsung sin tener un resultado positivo!

    Nota: despues de cambiar los HD ya no me manda ese error pero en cualquiera que le instale se queda en la pantalla que ya envie! espero sus comentarios, gracias.



  • ¿Qué tipo de disco es?

    ¿Es P-ATA? La manguera tiene que ser de 80 pines, FreeBSD no funciona con cables de 40 pines.



  • El disco es IDE, ya probé también con ATA y es el mismo resultado!

    La manguera es de 80 pines.

    Acabo de intentarlo en otra maquina con una mother Asus y es el mismo resultado no se que pasa!



  • ¿De qué partes, de un CD, de un lápiz USB?

    Igual tienes el soporte de pfSense mal…

    ¿Comprobaste la imagen de pfSense después de descargarla?

    Por cierto, RC1 quiere decir primera versión candidata a definitiva. Deberías bajarte la 2.0 actual (definitiva).



  • Parto de un CD, ya lo probé en la versión 2.0 Release, después con la 2.0 RC1 pensando que fuera la versión ya que en 2.0 Release ya no trae la opción de un solo procesador y el resultado sigue siendo el mismo.

    Ya agote toda posibilidad creo yo, estoy por desistir y probar en otro equipo.


  • Rebel Alliance

    Yo lo que haría para descartar CD o PC, seria, en lugar de iniciar la instalacion, dejaría que termine el proceso de "booteo" desde CD, a ver si tu CD está OK, y despues, asignaria la interfaces, si todo da OK, entonces iniciaria la instalacion ( opcion 99, si mal no recuerdo )

    Con respecto al kernel multiprocesador (SMP), no hay problema, yo tengo instaldo el pfSense 2 Release, en un PIII 500 y en un AMD Duron 800 ….

    Saludos



  • Les comento mis hallazgos respecto este punto:

    1.- Concluyo que si es falla de la mother o compatibilidad pues ya nunca paso del error posteado al inicio, lo raro es que si estuvo jalando bien durante 6 meses aprox.

    2.- Termine recuperando un CPU casi cadáver en mi cementerio de equipos y sorpresa esta tiene una mother Asrock soket 478 con un procesador amd Atlon y jalo perfecto…

    Solo una duda y pregunta para los expertos en este tema, cuando empezó la instalación me mando el error: /sbin/fdisk -v -f /tmp/format.fdisk ad1
    FAILED whit a return code of 1.

    Por lo que veo es error de algun sector del HD sin embargo el pfsense esta trabajando muy bien, si lo dejo así creen que pase algo?



  • Parece un error de que no pudo configurar el slice ad1

    http://www.freebsd.org/cgi/man.cgi?query=fdisk

    Igual estás trabajando con ad0 y ad1 es el segundo slice para upgrades. En la versión nano es así y a veces hay máquinas que no soportan tener este segundo slice. Entonces queda la solución de no tener el slice para upgrades. Nada más.

    Puedes ver qué puntos de montaje tienes en la consola con el comando df.

    http://www.freebsd.org/cgi/man.cgi?query=df


Log in to reply