Web interface crash while installing packages on NANOBSD



  • Hi all,

    I had some issues when trying to install the squid package through the webinterface. My platform is an alix board ( 500Mhz and 256 MB ram ) with 2gb industrial cf card.
    Whenever I try to install the squid package the installation starts, it gets to the point of installing perl ( a required dependency I presume ) and then it hangs there, with the browser reloading the page forver. If I try to access any other page ( opening a new tab ) on the web interface it won't work. Ssh in the meantime works fine, so I reckon it's just the webinterface.
    Running top did not show any obvious process running crazy. /var/log/system log file didn't report anything too.
    I have not tried installing any other package for now. Running the very same version of pfsense ( latest stable ) on a virtual machine didn't show any problem.

    Thanks


  • Rebel Alliance Developer Netgate

    Perl takes quite a long time to install on nanobsd. It takes a long time to download, and a long time to extract/install. How long did you let it go?



  • hi,

    I left it running for about 15 minutes, but interestingly enough the pkg/zip/whatever other process name running which was installing the packages finished already, I checked with top.
    However the webgui was still not responding to http/https requests.


Log in to reply