PfSense 2.0 sarg kurulumu - (Squid Analysis Report Generator)



  • Merhabalar,

    Lightsquid i sevmeyenler ve sarg tan vazgeçemeyenler kurulumu aşağıdaki gibi yapabilirler.

    sarg paketimizi kuralım

    pkg_add -r ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-8-stable/Latest/sarg.tbz
    

    vi ile uğraşamam, nano her işimi görüyor derseniz

    pkg_add -r ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-8-stable/Latest/nano.tbz
    

    config dosyamızı oluşturalım ve düzenleyelim.

    cd /usr/local/etc/sarg/
    cp sarg.conf.default sarg.conf
    nano sarg.conf
    

    Örnek olarak

    access_log /var/squid/log/access.log
    graphs yes
    graph_days_bytes_bar_color orange
    title "Squid User Access Reports"
    output_dir /usr/local/www/squid-reports
    resolve_ip no
    topuser_sort_field BYTES reverse
    user_sort_field BYTES reverse
    

    sarg a çalışma izni verelim

    cd /usr/local/bin
    chmod +x sarg
    

    Son olarak ta çalışmasını zamanlıyalım. bu örnekte her gece yarısı raporlama yapacak. Bu kısmı daha denemedim ama mantıken yapması gerek :)

    #crontab -e    
    01 * * * *   root /usr/local/bin/sarg
    

    /usr/local/bin/sarg yazarak ilk raporunuzu oluşturabilirsiniz.

    pfsense_ip/squid-reports adresinden de oluşan rapora bakabilirsiniz.



  • teşekkürler güzel anlatım icin eline saglık..:) :)



  • çok faydalı bir bilgi
    konuyu 1-2 hafta en üstte tutacağım.



  • çok güzel bir bilgi olmuş ellerinize saglık



  • Elinize sağlık. Hemen kurulumu denedim ancak aşağıdaki paketlerin güncel olmadığı uyarısını yaptı. -f parametresiyle force yapsam bir sorun olur mu acaba?

    pkg_add: warning: package 'sarg-2.3.1' requires 'expat-2.0.1_2', but 'expat-2.0.1_1' is installed
    pkg_add: warning: package 'sarg-2.3.1' requires 'png-1.4.8', but 'png-1.4.4' is installed
    pkg_add: warning: package 'sarg-2.3.1' requires 'png-1.4.8', but 'png-1.4.5_1' is installed
    pkg_add: warning: package 'sarg-2.3.1' requires 'freetype2-2.4.7', but 'freetype2-2.4.3' is installed
    pkg_add: warning: package 'sarg-2.3.1' requires 'freetype2-2.4.7', but 'freetype2-2.4.4' is installed
    pkg_add: warning: package 'sarg-2.3.1' requires 'fontconfig-2.8.0_1,1', but 'fontconfig-2.8.0,1' is installed

    Teşekkürler



  • kurulmda bu hataları vermesine rağmen çalışıyor bende.
    siz çalıştırıp rapor oluşturmadınız mı ?



  • Haklısınız. Hataları verince kurmadı sandım, raporumu oluşturdum.

    Teşekkürler



  • can not create squidguard report


Log in to reply