Squid Guard Apply



  • Merhaba Squid +Squid Guard kurdum.Gayet iyi çalışıyor.Ancak SquidGuard'a birdeğişiklik yaptığımda (Örneğin bir kategoriyi yasakladığımda) ve General Tabında apply butonuna bastıktan sonra.Yasakladığım ve serbest bıraktığım siteler için 20 -30 saniye  beklemeli olarak cevap alıyorum.Ancak bir 10 dakika geçtikten sonra çok hızlı cevap alıyorum.Acaba bu 10 dakikalık (Yaklaşık) süreçteki yavaşlığın nedeni nedir , bir çözümü var mıdır?



  • Proxy server: Cache management

    Level 1 subdirectories  16 olması lazım zaten aşağıdada belirtiyor..

    "Each level-1 directory contains 256 subdirectories, so a value of 256 level-1 directories will use a total of 65536 directories for the hard disk cache. This will significantly slow down the startup process of the proxy service, but can speed up the caching under certain conditions."

    birde http://forum.pfsense.org/index.php/topic,36731.15.html linkteki işlemleri yaparsan hızlanır



  • Öncelikle ilginiz için teşekkür ederim.

    Proxy server: Cache management -> Level 1 subdirectories değeri zaten 16'da idi.Daha küçük değerle (4) ilede denme yaptım sonuç değişmedi.

    Önerdiğiniz Topic'deki ayarlamalara da baktım benimkine çok yakın değerler di zaten , ancak yide oradaki değerler ile de deneme yaptım sonuç değişmedi.

    Aslında soruyu sorarken vurgulama yapacağım yerde yanlışlık yapmış olabilirim.Benim sistemimdeki yavaşlık yaklaşık 10 dakika için geçerli oluyor .Sonrasında zaten çok yüksek bir hızda cevap alabiliyorum.

    Sorumu tekrar şu şekilde sorayım:SquidGuard'a filtrelemelerde bir değişilik yaptıktan ve General Tabındaki APPLY butonuna bastıktan sonra yaklaşık 10 dakikalık bir süre için yasaklı ya da serbest bırakılmış siteleri açmaya çalışırken yavaş cevap almam normal mi? Bu tecrübeyi yaşayan var mı?



  • @mahoon:

    Öncelikle ilginiz için teşekkür ederim.

    Proxy server: Cache management -> Level 1 subdirectories değeri zaten 16'da idi.Daha küçük değerle (4) ilede denme yaptım sonuç değişmedi.

    Önerdiğiniz Topic'deki ayarlamalara da baktım benimkine çok yakın değerler di zaten , ancak yide oradaki değerler ile de deneme yaptım sonuç değişmedi.

    Aslında soruyu sorarken vurgulama yapacağım yerde yanlışlık yapmış olabilirim.Benim sistemimdeki yavaşlık yaklaşık 10 dakika için geçerli oluyor .Sonrasında zaten çok yüksek bir hızda cevap alabiliyorum.

    Sorumu tekrar şu şekilde sorayım:SquidGuard'a filtrelemelerde bir değişilik yaptıktan ve General Tabındaki APPLY butonuna bastıktan sonra yaklaşık 10 dakikalık bir süre için yasaklı ya da serbest bırakılmış siteleri açmaya çalışırken yavaş cevap almam normal mi? Bu tecrübeyi yaşayan var mı?

    hımm anlattığınız durum normal değil anında cevap vermesi gerekir.. squid ve s.guard paketlerini reinstall etmenizi öneririm eğer sorun devam ederse de gerekli configrasyonun yedeğini alıp tekrar kurmanız yararlı olacağı kanaatindeyim..

    saygılar



  • ama bunları logları temizledikten sonra denemeni öneririm

    1incisi Squid servisini stop ediniz.
    konsoldan
    ilk önce Squid servisini stop ediniz.
    Code:
    rm -rf /var/squid/cache/*
    rm -rf /var/squid/log/*
    şeklinde putty üzerinden komutları yazarak log ve cache edilmiş dosyaları silebilirsiniz silme işlemi diskteki verilerin büyüklüğüne göre uzun sürebilir.
    Kolay gelsin.



  • Psense silip yeniden 2.0.1 (2.0 kullanıyordum) olarak kurdum paketleri de sıfırdan kurunca anında cevap almaya başladım.

    Tekrar teşekkürler..


Log in to reply