Firewall HELP! Need ports opened.



  • So, I was a huge Endian Firewall Fan and recently decided to test out pfSense.  So far, I like it.

    One of the major issues that I am having is as follows and I have probably spent already 3 hours trying to figure out what is going on:

    1.  I can not open ports on the firewall.  I tried to enter the rules using the GUI, and it just doesnt want to open the ports up for me. 
    2.  I then thought it could have been my server behind the firewall, so I completely disabled the firewall on there, and the issue is still happening.

    I am just trying to open ports 80, and 443.  But I am not sure what I am doing wrong.

    Can someone help me out?

    Thanks.
    Ravi



  • Can you screen shot and paste your WAN rules in here? There is not much we can do to help unless we have a bit more details.



  • Attached are the rules I put under the Firewall.  Should these instead go under NAT?

    Basically, it is an exchange server that I am trying to open the ports for.




  • Configure it on nat rules.

    at bottom of nat creation tab, there is an option to associate this nat to a rule.

    Also change your pfsense gui port to https and any port other then 443.

    This will prevent conflict between pfsense gui and your nat server https port.



  • Nope, same thing.  Here are a couple of more attachments with the logs.

    I have never had this much trouble setting up a firewall before.

    If anyone can help, that would be great.  If not, it is back to my old firewall for the time being.

    ![Capture 2.PNG](/public/imported_attachments/1/Capture 2.PNG)
    ![Capture 2.PNG_thumb](/public/imported_attachments/1/Capture 2.PNG_thumb)



  • Ok figured it out.  If someone needs this again, this is what I did.

    man that was fun!!!

    ![Capture 2.PNG](/public/imported_attachments/1/Capture 2.PNG)
    ![Capture 2.PNG_thumb](/public/imported_attachments/1/Capture 2.PNG_thumb)



  • You got it, Source port must be any to work.

    good luck with pfsense, it's a GREAT firewall.



  • Your biggest issue is that is that your source port is not any. You will have the same problem if you did the same in NAT.


Log in to reply