Can't Remote Desktop if the machine has 2 NIC (internal/external)



  • Can't remote desktop thru openvpn because of routing issue or something else? Here is my setup…

    ComputerA has 2 NIC card with 1 being external and 1 being internal.

    External NIC:
    IP: 201.123.123.123
    NETMASK 255.255.255.0
    DEFAULT GATEWAY: 201.123.123.1

    Internal NIC:
    IP: 10.1.1.123
    NETMASK 255.255.255.0
    DEFAULT GATEWAY NONE

    PFSENSE:
    WANIP: 201.123.123.122
    LANIP: 10.1.1.1

    PFSENSE's OPENVPN:
    Tunnel Network: 10.1.2.0/24
    Local Network: 10.1.1.0/24

    I think the problem is that when I try to Remote Desktop into ComputerA thru OpenVPN with my connected openvpn IP being 10.1.2.6, ComputerA is routing the respond packet back to 201.123.123.1 which is the default gateway when it is suppose to be actually going back to the pfsense server 10.1.1.1.  Do I fix this by adding a static route that routes all 10.1.2.0/24 packets to 10.1.1.1 on ComputerA? If so, how would you do it on window 2008R2? Or am i missing something else and this is completely a bad way of setting it up or there is another way of fixing this problem... Oh and my local ip is 192.168.x.x....

    Thanks!



  • Seems like adding that static route into ComputerA fixed it….  Anyone know if there is a better way to fix this issue without having to add the static route to every machine that I want to be able to openvpn + remote desktop into that has that following 2 NIC setup?



  • The static route is the only solution, though you should just be able to set a static route for 10.1.2.0/24 on any machine that is dual-homed (the technical term for a machine connected to multiple networks).

    If that is too much of an overhead, consider removing the direct WAN connection for those hosts.


Log in to reply