Vlan Tagged + Switch D-Link DGS 1100



  • Buenas,

    Tengo el siguiente escenario:

    • VLAN 10, VLAN 172, VLAN 192.
    • Subred, 10.0.0.0 (VLAN 10), Subred 172.16.10.0 (VLAN 172), Subred 192.168.10.0 (VLAN 192).
    • Ethernet (em0) con las tres VLAN's asignadas.
    • IP de GW para cada VLAN.
    • Reglas de FW que permite todo el trafico de cada VLAN.
    • En el Switch tengo un puerto configurado como Tagged y asignado a cada VLAN (10, 172 y 192).

    En principio con esto entiendo que tendría que ser suficiente para tener conectividad con el GW, pero no, el GW de cada VLAN es inaccesible.

    Lo que no me queda claro es si es del pfSense o si es del Switch.

    ¿Alguna idea?

    Gracias.



  • No termino de comprender el montaje.

    Una boca de tu switch que pertenezca a les tres VLAN debe estar conectado a la LAN de pfSense.

    Tienes que definir las 3 VLAN en la interfase LAN de pfSense y activarlas (con sus respectivas IPs).

    Con esto tendrás tres nuevas pestañas de reglas, una para cada VLAN. Como si tuvieras 3 nuevas LAN.

    Reglas para cada VLAN y asunto concluido.

    Evidentemente la tarjeta que tengas en la LAN de pfSense tiene que soportar tagging.



  • Es justo lo que tengo hecho.

    Solo me queda pensar, que exista la posibilidad de que la ethernet no soporte el tagging.

    Miraré las especificaciones de la ethernet.

    Muchas gracias.



  • He mirado las especificaciones, y en teoría ha de soportar el tagging.

    Es una Intel Gigabit CT Desktop.

    Ahora si que no entiendo nada :S



  • ¿Reiniciaste? A veces las VLANs no operan bien hasta reiniciar.



  • Ya lo he solucionado.

    El problema era que la interface em0, estaba down, probé a mano en la shell a levantarla (ifconfig em0 up) y todo empezó a funcionar correctamente.

    He creado una interface asignada a em0 en pfsense, sin ip, para que esa interface quede siempre up y listo.

    Saludos y gracias.


Locked