[Solved] OpenVPN Bridge



  • Hi,

    I've got an OpenVPN bridge running on pfsense 2.0. I applied the bridge fix patch.

    Almost everything is working, except I have an issue where LAN machines cannot access the remote machine.

    Remote machine can access everything on the lan (but netbios doesn't seem to be working reliably, I can only access some windows machines by their name, but that isn't a big issue).
    PfSense can ping the remote machine (using it's local address)
    Lan machines cannot access the remote machine.

    I have no idea where to look for this one. It is a bridge, so firewall rules shouldn't come into it. All client machines are windows. I've disabled the firewall on the remote windows client so that isn't the issue. Is is almost as if the bridge is only allowing packets from OpenVPNTap->Lan, but not LAN->OpenVPNTap which doesn't make sense to me!.

    Any help or things to try would be greatly appreciated. I just want it to transparently bridge everything so it is exactly like I am on the local network.

    I don't know if it makes any difference that pfSense is running in a Virtualbox VM. Everything else with it seems to be fine.

    Thanks!



  • No worries. I updated to pfSense 2.0.1 and it works now.



  • Hey,

    I am trying to setup the same type of VPN. I was wondering how you did it in version 2.0.1? I have looked around but was not able to find any solutions.

    Thanks.



  • I applied the OpenVPN Fix patch (in the packages menu in pfsense).

    Then I created a VPN and set it to TAP (instead of TUN). Then under the bridge setting I bridged it to LAN.

    Then you need to manually create an interface (interfaces->assign) for the openVPN interface (and make sure to enable it, it doesn't need an IP or anything)

    Then you need to manually create the bridge by bridging the OpenVPN interface and LAN interface.

    And that's about all I did I think.



  • Awesome thanks for the quick reply that worked! Just a note I added in a DHCP IP Range when configuring the OpenVPN server or else my client would not receive an local IP when connecting.

    Cheers!


Locked