Building drivers with ndisgen belkin F9L1001v1



  • Hi all,

    I am running pfSense 2.0.1-Release (amd64)
    I am attempting to create drivers for use with my Belkin N150 wireless usb dongle (F9L1001v1) using ndisgen as shown here:
    http://devwiki.pfsense.org/UsingProjectEvilOnpfSense

    I have uploaded the following two files (Windows 7 x64) to the pfsense box:
    net8192su.inf - http://dl.dropbox.com/u/11017049/net8192su.inf
    rtl8192su.sys - http://dl.dropbox.com/u/11017049/rtl8192su.sys

    When I run ndisgen on the pfsense box I do the following:
    Select option 3- Convert Driver
    path to inf file (This .INF file appears to be ASCII.)
    path to sys file (This .SYS file appears to be in Windows(r) PE format.)
    press enter to convert files using ndiscvt (Conversion was successful)
    no firmware files
    generate kernel driver module
    Generating Makefile….. done
    Building kernel module... /usr/sbin/ndisgen: /usr/bin/make: not found
    build failed. Exiting.

    It looks like everything goes fine until it tries to run /usr/bin/make
    I can't find 'make' in the /usr/bin directory

    Any ideas on where I can get make???? or can someone with a freebsd install run the conversion for me (I can't seem to find any developer ISO's of pfsense anywhere...)



  • You can get a 8.1 iso from ftp.freebsd.org (or maybe ftp-archive.freebsd.org if they've moved it, don't think so yet though) and install it to a VM and pull the files over. Not sure how well that'll work for you though, it's not really something I'd recommend for serious production use. I've used it with a laptop before and it worked, but required an occasional ifconfig down/up and other mucking around with, wasn't extremely reliable.



  • built the drivers on another machine running freebsd 8.1 amd64

    moved the .ko file to the pfsense box and ran kldload ndis and kldload driver.ko

    was getting exec errors for both this usb dongle and a netgear usb dongle on the pfsense machine

    gonna return the two usb dongles and get a D-Link DWA-556 and pop it in, lets see if this works…..



  • put the D-Link DWA-556 card into the machine, works fine.  Didn't have to load any drivers or do anything special, pfSense 2.0 detected the card and used the right drivers (atheros chip on this card).


Locked