Uso de pkg_add -r



  • Haciendo pruebas (pfSense 2.0.1) de instalación manual de paquetes encontré el siguiente problema:

    [2.0.1-RELEASE][admin@pfsense.localdomain]/root(2): pkg_add -r coovachilli
    Error: Unable to get ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-8.1-release/Latest/coovachilli.tbz: File unavailable (e.g., file not found, no access)
    pkg_add: unable to fetch 'ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-8.1-release/Latest/coovachilli.tbz' by URL
    

    pfSense 2.0.1 busca los paquetes en lugar incorrecto.

    ¿Qué hacer?

    Hay que ejecutar la orden de consola:

    cp /etc/skel/dot.tcshrc /root/.tcshrc
    

    https://redmine.pfsense.org/issues/2075

    No es necesario reiniciar. Bastará con hacer exit y volver a usar la opción 8) Shell del menú de consola para que se lea la variable PACKAGESITE y podamos instalar sin problemas:

    [2.0.1-RELEASE][admin@pfsense.localdomain]/root(1): pkg_add -r coovachilli
    Fetching ftp://ftp-archive.freebsd.org/pub/FreeBSD-Archive/ports/i386/packages-8.1-release/Latest/coovachilli.tbz... Done.
    
    | Add coovachilli_enable="YES" to /etc/rc.conf
    |
    | You'll need to tweak your kernel settings
    | add the following to /boot/loader.conf
    | kern.ipc.msgseg=16000
    | kern.ipc.msgmnb=16000
    |
    | Sample config files located in %%EXAMPLESDIR%%
    | copy the sample main.conf file to your
    | chilli directory & create an empty
    | hs.conf & local.conf to get going.
    

    Recuérdese que esto es instalación manual de paquetes. No hay control de éllos vía web y tampoco se instalan sus dependencias…

    Saludos,

    Josep Pujadas


Locked