[решено]и вновь порт маппинг



  • вроде все темы перечитал. всё равно никак не получается сделать порт маппинг на 80 порт

    Интерфейсы: LAN: 192.168.1.1
    WAN: получает по DHCP от прова. локалка прова.
    OPT1: PPtP инет от прова.

    в Firewall | Nat добавил 2 правила
    WAN TCP * 80 (HTTP) WAN address 80 (HTTP) 192.168.1.40 80 (HTTP)
    OPT1 TCP * 80 (HTTP) OPT1 address 80 (HTTP) 192.168.1.40 80 (HTTP)

    из инета не заходит. из локалки по внешнему адресу переходит на pfsense и выводит Potential DNS Rebind attack detected, see http://en.wikipedia.org/wiki/DNS_rebinding
    Try accessing the router by IP address instead of by hostname.

    По факту нужно заходить на веб сервер из инета и из локалки по домену. Подскажите, где косяк у меня?



  • Измени порт входа на веб морду ПФ.

    http://thin.kiev.ua/images/stories/pfsense/vhost/adminka.JPG

    Либо HTTPS включи.

    @poteh:

    OPT1 TCP * 80 (HTTP) OPT1 address 80 (HTTP) 192.168.1.40 80 (HTTP)

    Это лишнее правило. Достаточно одного на WAN
    Поставь галку http://thin.kiev.ua/images/stories/pfsense/redir/red3.JPG



  • порт изменил, но там чуть ниже нужно галочку поставить

    WebGUI redirect	 Disable webConfigurator redirect rule 
     When this is unchecked, access to the webConfigurator is always permitted even on port 80, regardless of the listening port configured. Check this box to disable this automatically added redirect rule.
    

    и тогда не редиректит на веб морду

    правило для OPT1 убрал. Галочка стоит. Толку нет.
    изнутри по адресу 192.168.1.40 нормально функционирует веб сервер.



  • Невнимательно читал. Похоже правило для пптп було нужно.

    Вам необходимо изменить порт для админки ПФ и сделать редирект. Все должно работать.

    http://thin.kiev.ua/index.php?option=com_content&view=article&id=399:-pfsense-20&catid=50:pfsense&Itemid=81
    http://thin.kiev.ua/index.php?option=com_content&view=article&id=456:222&catid=50:pfsense&Itemid=81



  • по нулям.
    порт админки ПФ поставил 8888.
    правило для OPT вернул. галку Disable NAT Reflection for port forwards и ставил и убирал - толку 0.



  • поправочка. убрал галку Disable NAT Reflection for port forwards, удалил все правила. создал правило только для OPT1. Из инета появился доступ, из сети доступа нет.
    P.S. изнутри сети тоже появился доступ. всем спасибо)



  • Добрые человеки, чегой то не могу 22 порт пробросить, такое возможно вообще?



  • Ниче не понимаю, пробрасываю, из локалки нормально телнетом цепляется на внейший айпи, из инета "сбой подключения"



  • @tim2000:

    Ниче не понимаю, пробрасываю, из локалки нормально телнетом цепляется на внейший айпи, из инета "сбой подключения"

    1. Вопрос задайте нормально с айпи и задачами.
    2. измените на ПФ порт SSH
    3. Куда форвардите, для него ПФ должен быть шлюзом по умолчанию. Либо доп равила надо делать.
    4. И чего вы уперлись в 22 ой порт? Измените порт на никс сервере.



  • dr.gopher пасиба, после пары ребутов заработало, так и не понял что за глюк был.. ссх на сенсе отключен вовсе, у меня. :)


Log in to reply