FTP Problems in Routing Mode with public IPs



  • Hello, everybody!

    I have got a strange problem regarding my FTP-Servers…
    I have set up a routing system as followed:
    WAN-IP of pfSense: 80.xxx.147.66 / 28
    LAN-IP of pfSense: 10.0.2.1
    OPT1-IP of pfSense: 80.xxx.152.1 /24

    pfSense: 1.0.1-SNAPSHOT-03-27-2007
    (tried it before also with 1.0.1-SNAPSHOT-02-27-2007)

    I had the system in bridged mode before and the connections to the
    FTP-Servers in the OPT1-Interface worked perfectly.
    Now that I got the new WAN-Net, I had to switch (and wanted to switch)
    to Routing and now the FTP-Connections from Outside to OPT1 don't work
    at all.

    I have opened Port 21 from WAN -> OPT1 for each FTP-Server:
    TCP  *  *  Cochrane  21 (FTP)  *      FTP

    But FTP is not working, not in passive and not in active mode :-(
    It always "locks" up at the LIST command.

    And that's very bad as our customers are now locked out of their domains :-(

    I have tested all possible combinations of disable and enable FTP-Helper
    in WAN and OPT1-Interface.

    Currently WAN, LAN and OPT1 have FTP-Helper enabled (checkbox NOT checked).

    Here are some outputs on the pfSense:

    ps awux | grep ftpx

    proxy    368  0.0  0.0  656  416  ??  Ss  Fri10PM  0:01.35 /usr/local/sbin/pftpx -c 8021 -g 8021 10.0.2.1
    proxy    376  0.0  0.0  656  448  ??  Ss  Fri10PM  0:01.33 /usr/local/sbin/pftpx -c 8022 -g 8021 80.xxx.152.1

    ps awux | grep ftpsesame

    I have tried to read all threads here regarding FTP-Issues but most of them address
    NATing-Problems which I don't have  ;)

    I would be really happy if you could help me to solve this problem :-)

    Thanks a lot and happy eastern to you all!

    Best regards,

    Christian



  • Update:

    There seems to be a problem with the FTP Helper which is currently being investigated…
    In the meantime I have forwarded the passive FTP-Ports manually ;-)

    Thanks a lot, Hoba!  :)


Log in to reply