WAN problem/bug (at OpenVPN) when upgrading from 1.2.3



  • Scenario

    Upgrading from 1.2.3 to 2.0 or 2.0.1

    Two OpenVPN servers at WANx (OPTx).
    Upgraded loading the 1.2.3 config.xml

    Result

    The OpenVPN servers are migrated at WAN.

    Solution

    I had to reassign the interfaces used by the OpenVPN servers.

    Regards,

    Josep Pujadas


  • Rebel Alliance Developer Netgate

    1.2.3 had no interface selection for OpenVPN, so it was equivalent to setting the interface to 'any' in the GUI.

    I changed the upgrade code to assume 'any' for the interface on upgrade rather than 'wan' so it should be a non-issue on future upgrades of this type.


Log in to reply