DNS problem/bug (at OpenVPN) when upgrading from 1.2.3



  • Scenario

    Upgrading from 1.2.3 to 2.0 or 2.0.1

    OpenVPN server with more than one DNS client configured. Example: 192.168.0.2;192.168.0.3

    Upgraded loading the 1.2.3 config.xml

    Result

    The OpenVPN server has a wrong DNS1 client configured. Example: 192.168.0.2;192.168.0.3

    Solution

    I had to edit manually DNS1 & DNS2 boxes, putting one DNS in each box.

    Regards,

    Josep Pujadas


  • Rebel Alliance Developer Netgate

    You have started a bunch of separate threads for these, but in this case it would probably be better under a single thread.

    We would need a copy of your config.xml from 1.2.3 and the upgraded 2.0 config.xml as well to see what might have gone wrong there.

    If you do not want to post the configs here, you can e-mail them to me at jimp (at) pfsense [dot] org.



  • Jimp,

    I'm sorry for the bunch of posts. I thought there were 3 different situations upgrading pfSense+OpenVPN.

    I will send at your e-mail my two config.xml.

    Thanks,

    Josep Pujadas


  • Rebel Alliance Developer Netgate

    They are separate issues but collectively they are all upgrade problems and it's easy to miss them all in several separate threads. We haven't had any reports of broken 1.2.3 config upgrades in quite some time so keeping them together is preferable in this case.



  • Jimp,

    On Jan-12 I sent to you the config.xml by e-mail.

    Did you receive them?

    Subject: Last 1.2.3, first 2.0.1 config.xml

    Regards,

    Josep Pujadas


  • Rebel Alliance Developer Netgate

    yes I did, but I haven't had any time to look at it.


  • Rebel Alliance Developer Netgate

    This one (for DNS) also affected NTP and WINS servers. I committed a fix to the upgrade code to split them out properly.


Log in to reply