Portal captive



  • Buenos dias

    Espero que alguien me pueda responder mi duda, tengo pfsense 1.2.3 en un equipo para repartir el internet inalambrico, y mediante local user autentico mi red en con el portal captive, solo que ahora al querer accesar no me muestra el logeo, se puede conenctar al la señal de la red pero no entra el logeo a la misma y por lo consiguiente no entra a internet, tengo otros usuarios que estan dados de alta por la dirección mac y estos si pueden entrar, alguien sabrá que habrá pasado por que ya no se pueden autenticar usuarios? de antemano gracias por sus respuestas



  • tengo otros usuarios que estan dados de alta por la dirección mac

    Supongo que con esto te refieres a bypass del portal cautivo.

    Si te funciona el bypass y no te muestra el portal para el resto esto quiere decir que el portal cautivo no debe estar funcionando.

    Las causas pueden ser varias. Piensa en si has hecho cambios en reglas o en el DNS:

    http://doc.pfsense.org/index.php/Captive_Portal_Troubleshooting#Captive_portal_not_redirecting

    Los clientes tienen que tener acceso a un DNS o al DNS de pfSense y a salida HTTP. De lo contrario el portal no se dispara.

    Saludos,

    Josep Pujadas



  • hola de nuevo, si estoy haciendo lo que comentas pero el problema es que de repente entra el portal captive y en otras ocaciones no



  • ¿De qué forma toman las direcciones IP los clientes?

    ¿Cuál es su DNS? ¿pfSense, otro local o externo?

    ¿Salen los clientes directos a HTTP? ¿O pasan por proxy? ¿En pfSense? ¿Es transparente?



  • Las direcciones son con DHCP, el dns es uno local de la empresa, proxy de pfsense transparente



  • Tengo una situación parecida y…

    En la red que esté con el portal cautivo prueba a poner como DNS para tus máquinas el propio pfSense (Services - DNS Forwarder).

    Si esto te plantea problemas de resolución indica en System tu DNS local como primer DNS para pfSense.

    Y, además, en el DHCP de la tarjeta asociada al portal cautivo (Services DHCP Server) coloca este DNS local como el secundario, es decir, llena la primera casilla con la IP de la interfase de pfSense y la segunda con la de tu DNS local.

    Otra posibilidad es que añadas la IP de tu DNS local en Services - Captive portal - Allowed IP addresses para asegurar el bypass del portal.

    Del enlace que te dí…

    DNS resolution not functioning - the clients on the captive portal interface must either be using the DNS forwarder on pfSense, on the IP of the interface where the client resides (which is the default configuration), or if using some other IP for DNS, it must be an allowed IP entry. If DNS fails, the browser never issues the HTTP request, hence it cannot be intercepted and redirected.

    El portal se dispara en cuanto el usuario indica al navegador una dirección y el equipo pide la resolución DNS más la página web. Si una de las dos cosas falla, por la estructura que se tiene, el portal no funciona.

    Ya dirás….

    Josep Pujadas



  • gracias probare



  • gracias por la respuesta, pero ahora tengo otro problema ahora no me muestra las paginas en el explorador de los usuarios que estan en pass-through, si tiene acceso a internet pero al abrir el explorador las paginas no son mostradas.



  • ¿Y cuál es el cambio que hiciste finalmente?



  • lo que hice fue volver a poner los dns y reiniciar el sistema, ya no me ha dado problema el acceso con cuenta de usuarios, pero como comento los que estan por pass-trought no visualizan las paginas de internet aunque si muestra la coneccion como si tuviera



  • :) hola eriol72,

    has hecho cambios en el archivo index.html del captive portal?

    si hiciste algún cambio de lo básico del archivo fallara la conexión como nos comentas



  • hola, no he hecho ninguno, de hecho como comento antes los equipos que tenian acceso a internet eran las que estaban por el pass-trought y las que se loggeaban con el nombre de usuario, no veian la pagina de inicio de sesion, ahora es al reves los usuarios si se pueden loggear y los que estaban en pass-throught no, en el centro de redes y recursos compartidos me dice que si tiene acceso pero al entrar a un explorador y tratar de abrir una pagina no accesa. Lo que hice anteriormente fue volver a poner los dns y en allowed ip addresses pues la direccion de dns.



  • ¿ Miraste qué configuración DNS están tomando las máquinas con el bypass ?

    ipconfig /all (si Windows)
    nslookup para resolver…

    Dices que se conectan a Internet pero que no navegan. ¿Qué prueba hiciste? ¿ ping, por nombre, por IP ?

    Por favor, detalla más.

    Saludos,

    Josep Pujadas



  • el dns que tomas es mi direccion del pf sense, y entra al mensajero, pero al hacer ping a una pagina no da señal



  • No sé qué es el mensajero…

    Por favor, ¿ qué resultado da (por ejemplo):

    nslookup www.pfsense.org

    en una de las máquinas bypass ?

    ¿ ping, por nombre, por IP ?

    Hay que saber si estas máquinas están o no resolviendo… La apariencia es que no.

    Entonces lo que pasa es que:

    • Tienes un problema con las reglas en LAN y no permiten el acceso TCP/UDP 53 a la interfase de pfSense

    o

    • Tienes que especificar tu DNS interno más el de pfSense en el DHCP o en el squid transparente.

Log in to reply