DC Universe online fails to connect over VPN



  • Hey guys I hope someone could help with this issue ive been having. Im trying to connect to play DCUO from work over a VPN (WorkNet > VPN > DCUO) connection on a VPS server, but for some reason when connecting to DCUO from work while connected to my vpn server the game starts to load it will time out and disconnect me. Now I immediately thought it was the network at my workplace but when I try it at home I have the same problem when trying to connect (HomeNet > VPN > DCUO) through VPN. From home I can connect fine (no VPN). So then I proceeded to setup OpenVpn on my pfsense box at home, mind you its not the fastest connection but it will help with trying firgure out this problem. After setting that up I was able to establish a connection (WorkNet > HomeVPN > DCUO) get on the net and all that good stuff. Fired up DCUO and I am having the exact same issue. I have tried several different TCP/UDP ports and still no dice and setting all iptables rules to accept. So now I look to you guys :] below are my iptables rules and some links to some wireshark caps of successful home connections and unsuccessful VPN connections. Thanks to everyone on this form in advance.

    iptables script
    –--------------------------------------------
    #!/bin/sh

    PUB="173.234.50.101"

    iptables -A FORWARD -m state --state RELATED,ESTABLISHED -j ACCEPT

    iptables -A FORWARD -s 10.8.0.0/24 -j ACCEPT

    #iptables -A FORWARD -j REJECT

    iptables -t nat -A POSTROUTING -s 10.8.0.0/24 -j SNAT --to $PUB

    iptables -P OUTPUT ACCEPT

    iptables -P INPUT ACCEPT

    iptables -P FORWARD ACCEPT

    Wireshark captures.

    http://dl.dropbox.com/u/219009/caps....20adapter.pcap

    http://dl.dropbox.com/u/219009/caps....20adapter.pcap

    http://dl.dropbox.com/u/219009/caps....onnection.pcap


Log in to reply