Wireless router setup issues



  • I am currently trying to connect a wireless router running OpenWRT 8.09 to my pfsense box to provide wireless access. My interface configuration is as follows.

    Interfaces:
      WAN (DHCP, 10.0.0.2)      ->    Modem (Static, 10.0.0.1)
      LAN (Static 10.0.1.1)        ->    Switch
      WLAN (Static, 10.0.2.2)    ->    Wireless Router (Static 10.0.2.1)

    All devices connected to the LAN interface are able to access the internet, but devices connected to the WLAN interface are not able to get past pfsense, i have tried setting a firewall rule on the WLAN interface like the one that is on the LAN interface by default.

    Firewall Rule:

    • WLAN net * * * * none   Default allow WLAN to any rule

    Although i am still having no luck DHCP is working on the WLAN interface and clients that connect receive an IP address, but no connected clients or the wireless router itself can access the internet or any device connected to the LAN interface. If anyone can help me with this problem it would be much appreciated.



  • FRom what it sounds like, you are handing out dhcp address from pfsense? If you are handing them out from openwrt, then it might be using the wrong gateway address. If you are connecting the openwrt from its "WAN" port, you might have to disable the default firewall rules. What is the default GW on the WLAN machines? HAve you tried a traceroute to see where the traffic stops?



  • Have you checked the firewall log (Status -> System Logs, click on Firewall tab)?

    Did you reset firewall states (Diagnostics -> States, click on Reset States tab) or reboot after adding the rule to allow traffic from WLAN?



  • @wallabybob:

    Have you checked the firewall log (Status -> System Logs, click on Firewall tab)?

    Did you reset firewall states (Diagnostics -> States, click on Reset States tab) or reboot after adding the rule to allow traffic from WLAN?

    As you suggested i reset the firewall states, and then tried a trace route from the OpenWRT router while checking the firewall logs on pfsense.

    OpenWRT Trace Route Result:

    Please wait for output of "traceroute google.com" …

    traceroute: warning: google.com has multiple addresses; using 74.125.237.148
    traceroute to google.com (74.125.237.148), 30 hops max, 38 byte packets
    2  *
    4  *
    5  *
    6  *
    7  *
    8  *
    9  *
    10  *
    11  *
    12  *
    13  *
    14  *
    15  *
    17  *
    18  *
    19  *
    21  *
    22  *
    23  *
    24  *
    25  *
    26  *
    27  *
    28  *
    29  *
    30  *
    30  * * *

    Firewall Log Image is attached.

    ![firewall log.png](/public/imported_attachments/1/firewall log.png)
    ![firewall log.png_thumb](/public/imported_attachments/1/firewall log.png_thumb)



  • Ok i figured it out :), turns out i accidentally had the pfsense captive portal enabled on the WLAN interface. I turned it off and now have internet access haha.


Log in to reply