Pfsense v2.0.1 und squid



  • Hallo,

    habe mir gerade pfsense installiert. Läuft alles einwandfrei.
    Jetzt wollte ich noch den squid installieren, jedoch bekomme ich folgende Fehlermeldung:

    Parse error: syntax error, unexpected T_CONSTANT_ENCAPSED_STRING, expecting ')' in /usr/local/pkg/squid.inc on line 30

    Die selbe Fehlermeldung erhalte ich bei squid-reverse und squid3

    Wo könnte das Problem liegen?

    mexx



  • Jedenfalls nicht am Paket.

    Die Installation funktioniert bei mir.

    Evt. nochmal deinstallieren und neu installieren und
    Diagnostics -> Backup/Restore -> Clear package lock.



  • hallo,

    ich konnte das package auch nicht mehr deinstallieren > genau gleicher fehler.
    backup wollte ich auch machen, jedoch kam ich nur zu einer leeren seite.

    habe jetzt alles neu installiert.
    werde jetzt gleich probieren squid zu installieren. ich gebe dann bescheid.

    mexx



  • Evtl. irgendwas in der squid.inc defekt oder nicht korrekt heruntergeladen worden. Diese Datei ist sowohl für die Installation als auch die Deinstallation notwendig.

    Diese Datei liegt in

    /usr/local/pkg/
    

    evtl. hilft es zukünftig, diese Dateien dort zu löschen bzw. manuell zu ersetzen/checken.



  • hallo,

    jetzt hat bei der installation alles funktioniert.
    habe aber alles gleich gemacht wie das letztes mal…..
    komisch.

    mexx



  • Hallo,
    anhand folgender Anleitung habe ich squid installiert:
    http://doc.pfsense.org/index.php/Setup_Squid_as_a_Transparent_Proxy

    Er schreibt mir die besuchten Seiten auch ins Log.
    Aber wie schickt squid mir die aufgerufenen Seiten an meinen Syslog Server?

    Danke.


Log in to reply