AP for PSP



  • Hello;
    I set up an AP (atheros PCI card) which works with the PSP if there's no encryption, but it won't as soon as try to set up WEP or WPA.
    The PSP is supposed to support WEP, WPA-PSK TKIP and WPA-PSK AES.
    Someone knows how to set a AP with WPA that works with the PSP ?
    Thank you.
    Regards.



  • By default the webgui uses "both" (tkip/aes). Some clients have issues authenticationg with that setting. Try to set it to aes or tkip only. If using WEP make sure you have the correct setting for open or shared system (though I would prefer wpa-aes of course).



  • Thanks for your help.
    I tried both aes & tkip only. Still doesn't work, the problem must come from elsewhere.



  • <from a="" psp="" owner,="" who="" has="" yet="" to="" setup="" his="" own="" wap,="" but="" configured="" under="" others="">be sure you have the latest firmware (unless you're homebrewed'), and you are putting in the correct key. It can be a serious pain in the @ss putting the key in with the crappy PSP keyboard interface, be sure you have it right. Have you already tested WPA connection with another computer?</from>



  • The problem remain unsolved. Yes, I use the connexion frequently with different computer.
    Regards.



  • Question, do you have DHCP enabled? If it's not enabled, you have to 'Custom' and set it in your PSP itself. What error do you get with your PSP? Is it 'Access point not found?'? Unable to resolve IP (or anything like that?)?



  • yes DHCP is unabled. I have a recent firm 3.10'OE.
    So I tried again (I had gave up on this) the error is:
    "key information exchange timed out"

    Regards.



  • upgrade your PSP firmware. It seems 2.0 has this issue with WPA

    if you're already upgraded, reset your PSP settings to default, i've heard that might work

    and lastly use TKIP only, see if you can get it to work with that, then try for AES



  • Thanks for your help. My firmware is a custom one, it should have the same functionalities that the 3.10 from sonny.
    I tried TKIP/AES, wap/both(wap+wap2), g/b/both, etc.
    I'll try to reset settings to default this evening and let you know.
    Did you try yours with pfsense? what firmware do you use?
    I suspect the firm. to be responsible, I tried nearly all possible settings, the thing is if I upgrade to an official firmware I will not be able to run homebrew anymore :(

    Best.

    EDIT: By the way should I bridge LAN with WLAN?



  • Now I finally got an adapter yesterday, I used wireless for PFSense and am having the same problem. But the problem IS the PSP. I read a Sony forum where A LOT of people are having trouble with WPA on a wide variety of wireless routers. WEP does seem to work fine for me, but I won't enable it for security reasons


Log in to reply