Install pfsense 2.0 to WG Firebox X1000



  • Здравствуйте уважаемые.

    Имеется в наличие девайс WG Firebox X1000. Хочется чтобы он работал на Pfsense 2.0.
    Уже есть CF 4Gb с залитым туда образом (pfSense-2.0.1-RELEASE-4g-i386-nanobsd.img) через dd.
    Есть ли возможность заставить функционировать не перепрошивая биос устройства?
    После установки флешки  с pfsense достучаться не получается не по веб интерфейсу не по COM порту. Подозреваю что загрузка с накопителя не производится.
    Повторюсь. Интересует способ без перепрошивки биоса устройства или с возможностью отката к прежнему функционалу. Загрузку в HDD не рассматриваю (хочется именно с CF).

    Заранее благодарен за информативные и практические ответы.



  • не? Если я правильно понимаю, что есть по сути Ваш фаер.



  • @aleksvolgin:

    не? Если я правильно понимаю, что есть по сути Ваш фаер.

    Так не выходит. Распишу как чего делаю:
    1. Открываю FB
    2. Вытаскиваю флешку с WG OS
    3. Пишу образ pfSense-2.0.1-RELEASE-4g-i386-nanobsd.img при помощи dd

    # dd if=pfSense-2.0.1-RELEASE-4g-i386-nanobsd.img of=/dev/sdc bs=16k
    

    4. Вставляю флешку в FB
    5. Подсоединяю кабель консольный (Rs-232) (кабель рабочий, прошел не один FB, и другого железа)
    6. Включаю питание FB
    7. Пробую соединится.
      Пробовал на разных скоростях с разными параметрами.



  • Пробовал на разных скоростях с разными параметрами.

    если мне не изменяет память, по умолчанию RS232 консоль не включена в готовых образах, поэтому вы и не видите ничего. Загрузитесь с CF на обычной машине и включите RS232 консоль. А воткнув PCI видяху в ваш фаер можно увидеть лог загрузки сенса, там в самом начале должно быть про консоль.
    Параметры там что-то 9600/19200/115200 8N1.

    –------
    офф. ИМХО для 2-го сенса слабоватенький конфиг у вас. Если желаете именно сенс, то лучше 1.2.2/1.2.3 версии, или open-wrt for x86, а если хотите по максимуму, то такое.



  • если мне не изменяет память, по умолчанию RS232 консоль не включена в готовых образах, поэтому вы и не видите ничего. Загрузитесь с CF на обычной машине и включите RS232 консоль. А воткнув PCI видяху в ваш фаер можно увидеть лог загрузки сенса, там в самом начале должно быть про консоль.
    Параметры там что-то 9600/19200/115200 8N1.

    Вот тут небольшая статья. Насколько я могу судить tty выведен на COM порт в готовом образе.
    http://packetjunkie.net/2011/12/pfsense-on-a-watchguard-firebox-x550e-on-a-mac/



  • pfSense-2.0.1-RELEASE-4g-i386-nanobsd.img

    в этом образе RS232 консоль включена по умолчанию, я сейчас посмотрел (что тем не менее не мешает ему быть кривым: не удалось назначить em1 карту LAN интерфейсу, только WAN, бред какой-то).
    Попробуйте m0n0/openwrt раскать для проверки корректности железа, и видяху подключите, может что интересное углядите.



  • Итак. Удалось подключится к консоли. Меня очень долго долго и упорно просило, чтобы я сконфигурировал VLAN, на что я постоянно отвечал "n", на это получал предложение циклично. В итоге ответил "y", после появилось предложение выбрать WAN интерфейс (интерфейсы были re0, re1, re2, re3, re4, re5). Выбрал соответственно re0. После чего завершилось вот чем:

    Creating symlinks......done.
    External config loader 1.0 is now starting... ad0s3
    Launching the init system... done.
    Initializing............................ done.
    Starting device manager (devd)...done.
    Loading configuration......done.
    Updating configuration...done.
    Cleaning backup cache.....done.
    Setting up extended sysctls...done.
    Setting timezone...done.
    Starting Secure Shell Services...done.
    Setting up polling defaults...done.
    Setting up interfaces microcode...done.
    Configuring LAGG interfaces...done.
    Configuring VLAN interfaces...done.
    Configuring QinQ interre0: link state changed to DOWN
    faces...done.
    Configuring WAN interface...done.
    Syncing OpenVPN settings...done.
    Starting syslog...done.
    Configuring firewall......done.
    Starting PFLOG...done.
    Setting up gateway monitors...done.
    Synchronizing user settings...done.
    Starting webConfigurator...done.
    Configuring CRON...done.
    Starting DNS forwarder...done.
    Configuring firewall......done.
    Starting OpenNTP time client...done.
    Generating RRD graphs...done.
    Starting CRON... done.
    Bootup complete
    

    После этого в консоли не дает ничего сделать (никакой реакции). Попробовал соединится с web интерфейсом. Настроил на ноутбуке 192.168.1.3 255.255.255.0, но не на одном интерфейсе FB сеть не признал.

    После надписи "Bootup complete" он издает победный звук в спикерфон. Но так удалось лиш 2 раза. В основном просто не подключается к консоли и не издает никаких звуков.



  • Итак. Удалось подключится к консоли.

    и в чём грабли были?

    Меня очень долго долго и упорно просило, чтобы я сконфигурировал VLAN, на что я постоянно отвечал "n", на это получал предложение циклично. В итоге ответил "y", после появилось предложение выбрать WAN интерфейс (интерфейсы были re0, re1, re2, re3, re4, re5). Выбрал соответственно re0. После чего завершилось вот чем:

    я же говорю - кривой имидж, про настройку LAN совсем не спрашивает.



  • В чем были грабли я так и не понял. Пустило пару раз и на этом все закончилось.
    Как где-то писалось что теперь, с версии 2.0 pfsense конфигурит один интерфейс, а ланы подхватывает автоматом.
    m0n0wall запустился без проблем (теста ради). Но нужен именно pfsense.



  • Как где-то писалось что теперь, с версии 2.0 pfsense конфигурит один интерфейс, а ланы подхватывает автоматом.

    а как же это?

    Или после RC1 поменяли идеологию?



  • Попробую несколько образов. Для начала переберу по размерам (в надежде что создавались не с одной платформы). А дальше если не пойдет придется пробовать 1.2.3.
    Надо чтобы была нормальная поддержка L2TP для WAN, и адекватная установка (ну или близко к этому) Snort. Ну и вообще шикарно будет если подхватит SafeNet 1141.



  • Попробую несколько образов. Для начала переберу по размерам (в надежде что создавались не с одной платформы).

    Ваш случай?


    / f
    / p _
    / Sense
    _

        _
    _/

    Welcome to pfSense 2.0-RC1  …

    Creating symlinks......done.
    External config loader 1.0 is now starting... ad0s3
    appending output to nohup.out
    Launching the init system... done.
    Initializing............................ done.
    Starting device manager (devd)...done.
    Loading configuration......done.
    Updating configuration...done.
    Cleaning backup cache....done.
    Setting up extended sysctls...done.
    Setting timezone...done.
    Starting Secure Shell Services...done.
    Setting up polling defaults...done.
    Setting up interfaces microcode...done.
    Configuring LAGG interfaces...done.
    Configuring VLAN interfaces...done.
    Configre1: link state changed to DOWN
    uring QinQ interfaces...done.
    Configuring WAN interface...done.
    Configuring LAN interface...re3: link state changed to DOWN
    done.
    Syncing OpenVPN settings...done.
    Starting syslog...done.
    Configuring firewall......done.
    Starting PFLOG...done.
    Setting up gateway monitors...done.
    Synchronizing user settings...done.
    Starting webConfigurator...done.
    Configuring CRON...done.
    Starting OpenNTP time client...done.
    Starting DNS forwarder...done.
    Configuring firewall......done.
    Generating RRD graphs...done.
    Starting CRON... done.
    Executing rc.d items...
    Starting /usr/local/etc/rc.d/*.sh...done.
    Bootup complete
    --- snip ---

    Here it hangs - no further output ...

    А дальше если не пойдет придется пробовать 1.2.3.

    оно заработает.

    Ну и вообще шикарно будет если подхватит SafeNet 1141.

    однако нет тыц тыц. Карта может заработает в линукс маршрутизаторах.



  • Эх, случай вроде похожий, но у него хотя бы он загружается каждый раз (хоть и после старта системы больше ничего в консоль не выводит как у меня), а у меня только 2 раза загрузился. Больше я пока не смог добиться загрузки.



  • но у него хотя бы он загружается каждый раз

    там вроде сошлись на кривых дровах для 8139С+. Смотрите в сторону линукс.



  • Решил попробовать на pfsense 1.2.3. Картина получилась такой:

    Valid interfaces are:
    
    re0     00:90:7f:31:93:dc
    re1     00:90:7f:31:93:dd
    re2     00:90:7f:31:93:de
    re3     00:90:7f:31:93:df
    re4     00:90:7f:31:93:e0
    re5     00:90:7f:31:93:e1
    
    hitting 'a' to initiate auto detection. 
    
    Enter the LAN interface name or 'a' for auto-detection: a
    
    re0: link state changed to DOWN
    re1: link state changed to UP
    re2: link state changed to DOWN
    re3: link state changed to DOWN
    re4: link state changed to DOWN
    re5: link state changed to DOWN
    
    Connect the LAN interface now and make sure that the link is up.
    Then press ENTER to continue.
    No link-up detected.
    

    Далее опять спрашивает циклично про VLAN и если ответить "y"
    Говоришь что интерфейс LAN - re1, а в ответ постоянно

    Connect the LAN interface now and make sure that the link is up.
    Then press ENTER to continue.
    No link-up detected.
    

    Печально как-то…



  • Печально как-то…

    а если сетевушку в PCI32 воткнуть (intel/3COM) на время конфигурации в качестве LAN интерфейса?



  • @aleksvolgin:

    Печально как-то…

    а если сетевушку в PCI32 воткнуть (intel/3COM) на время конфигурации в качестве LAN интерфейса?

    Нужен переходник для PCI на горизонтальное положение, иначе упирается в корпус, а выкручивать мамку там целая история.
    Да и странно даже, видит же все интерфейсы.



  • Нужен переходник для PCI на горизонтальное положение, иначе упирается в корпус, а выкручивать мамку там целая история.

    оно?



  • Верно. Но если вставлять не вынимая MB, то край текстолита упирается в корпус и она не войдет в слот, а чтобы вошла нужно MB вытаскивать, а это отсоединять все что идет на морду.
    Сегодня попробовал Zeroshell поставить, загрузился без проблем. И того получается что Linux 2.6.* грузится, m0n0wall грузится без проблем (он тоже на FreeBSD 8.2, как и pfsense 2.0.*), а pfsense 2.0, 2.0.1, 1.2.3 - не загрузились.
    Странно же…



  • m0n0wall грузится без проблем (он тоже на FreeBSD 8.2, как и pfsense 2.0.*)

    а какую версию моно вы пробовали? Если 1.33, то там freebsd 6.4, на 8.2 только беты 1.8 пока.
    Версию 1.2.2 не пробовали, так для очистки совести? У меня несколько стендов на ней (правда карты только intel/3COM).



  • Действительно, ошибся. С m0n0wall я пока не понял как скрестить Snort и самое главное как увеличить до полного объема под флешку образ. Т.е. он пишет только 10Мб, а хотелось бы использовать все 4Гб, или хотябы 2Гб.
    Насчет fpsense появилась идея. Коли он не хочет признавать интерфейсы в момент конфигурирования, то можно попробовать указать ему заранее WAN и LAN порты. Подскажите в каких файлах это можно сделать и как сделать после этих изменений, чтобы он в момент загрузки не пытался конфигурировать их?



  • не понял как скрестить Snort

    да никак. m0n0 штатно не предусматривает установку дополнительных компонентов.

    как увеличить до полного объема под флешку образ.

    кажется только штатными средствами bsd сие возможно. А мы ленивые  :) мы акронис любим.

    Подскажите в каких файлах это можно сделать

    в последней партиции bsd в каталоге /conf есть файл config.xml там это храниться

    <interfaces><lan><if>ed2</if>
    <ipaddr>192.168.1.1</ipaddr>
    <subnet>24</subnet>
    <media><mediaopt><bandwidth>100</bandwidth>
    <bandwidthtype>Mb</bandwidthtype></mediaopt></media></lan>
    <wan><if>ed1</if>
    <mtu><blockpriv><media><mediaopt><bandwidth>100</bandwidth>
    <bandwidthtype>Mb</bandwidthtype>
    <spoofmac><ipaddr>pppoe</ipaddr></spoofmac></mediaopt></media></blockpriv></mtu></wan></interfaces>

    это кусок моего боевого конфига. Карты NE2000 совместимые (ISA  ;)) WAN интерфейс - PPPOE интерфейс подключен к ADSL модему.

    как сделать после этих изменений, чтобы он в момент загрузки не пытался конфигурировать их?

    а это шут его знает.



  • Удалось таки одержать победу. Я не знаю по каким причинам не работал нормально конфигуратор изначальной настройки. По вот этой статье http://doc.pfsense.org/index.php/Modifying_Embedded я изменил имена интерфейсов на свои (re*). Настроил под себя нужный IP LAN порта. Так же стоит упомянуть файл trigger_initial_wizard нужно обязательно удалить, чтобы не запускался конфигуратор. А далее все завелось без проблем. Я работал с pfsense 1.2.3, но думаю что и с версией 2.0.* будет все так же.

    P.S.:

    Драйвера для сетевых карт тут ни причем, тут косяк конфигуратора.

    Спасибо за помощь всем участникам темы.


Log in to reply