Asterisk 1.8 package



  • It's broken again, sent you a PM with the reason why.



  • @robi:

    It's broken again, sent you a PM with the reason why.

    Can you check again with latest changes?



  • The Asterisk package works now with pfSense 2.1. both full setup and NanoBSD.

    It includes a web interface for issuing basic or custom commands to asterisk console, calls log, system log, configuration files editing option, configuration directory backup and restore option.

    By default when installed on pfSense it's preconfigured for SIP operation, and has got two demo extensions, 301 and 302 which allow testing with real IP phones or softphones through the LAN interface.



  • hello
    tell here how to install chan-dongle? https://code.google.com/p/asterisk-chan-dongle/ ?

    PF 2.1
    Asterisk Services 1.8 pkg v0.3.1 Asterisk is an open source framework for building communications applications.
    Asterisk turns an ordinary computer into a communications server.



  • You need to compile it on freebsd 8.3



  • How cool… One could use Asterisk to place directly mobile calls through a supported 3G modem.



  • @robi:

    How cool… One could use Asterisk to place directly mobile calls through a supported 3G modem.

    Yes. I've tested it on linux and it works. The problem I had way with usb power supply for multiple 3g modem and power boot sequence some times.



  • Hi Marcelloc,

    First, thanks for your great work again…
    I was running a FreePBX server behind Pfsense, however it seems there are some NAT problem and I can't find any solution for that.
    Then I tried your Asterisk package, it works perfect  :D. The only question is it's difficult for me to edit the configurations... :-[
    I read your post and you have installed Asterisk-gui successful before, I am now sure it's still working for latest pfsense 2.1?
    Can I ask you to post a guide here?

    Thanks



  • I've not tested it on 2.1 yet and freebsd port is still pending.



  • @zlyzwy:

    Hi Marcelloc,

    First, thanks for your great work again…

    It's mainly a robi work. I just did some small modifications  ;)



  • @zlyzwy:

    The only question is it's difficult for me to edit the configurations… :-[
    [/quote]

    if it is only to modify the config file directly, you can do it this way (if you use windows) :

    • enable SSH in "System" -> "Advanced" - > "Admin Access" and check "Enable Secure Shell"
    • use WINCSP to access the files in /conf/asterisk/

    that's the way i modify my conf files for asterisk.

    I hope the GUI will be ported soon. :) Will be good to have a complete GUI to manage configuration.



  • Why don't you use edit configuration tab? ???



  • I am running the Asterisk 1.8 package on pfsense 2.1 and have the following issues:

    Everytime I reboot pfsense the following (demo) configuration text is added to sip.conf

    ==>

    [301]
    ;demo extension for pfSense
    type=friend
    defaultuser=301
    insecure=port,invite
    secret=1234
    regexten=301
    host=dynamic
    context=default

    [302]
    ;demo extension for pfSense
    type=friend
    defaultuser=302
    insecure=port,invite
    secret=1234
    regexten=302
    host=dynamic
    context=default

    <==

    Everytime I reboot pfsense my call history is lost
    Everytime I reboot pfsense my Asterisk log file is empty
    Everytime I reboot pfsense my personal voicemail message is gone

    Are there any sollutions to my above problems

    Thanks in advance

    Kr,

    Matthijs



  • What pfsense version are you using?



  • Like I said I am using pfsense 2.1 :)



  • @matthijs:

    Like I said I am using pfsense 2.1 :)

    i386, amd64, nanobsd?



  • O sorry

    2.1-RELEASE (i386)
    built on Wed Sep 11 18:16:44 EDT 2013
    FreeBSD 8.3-RELEASE-p11



  • PBX Core settings
    –---------------
      Version:                    1.8.19.0
      Build Options:              LOADABLE_MODULES
      Maximum calls:              Not set
      Maximum open file handles:  Not set
      Verbosity:                  0
      Debug level:                0
      Maximum load average:        0.000000
      Startup time:                21:41:43
      Last reload time:            21:41:43
      System:                      FreeBSD/8.3-RELEASE-p3 built by root on i386 2012-12-19 14:50:46 UTC
      System name:               
      Entity ID:                  xxx
      Default language:            en
      Language prefix:            Enabled
      User name and group:        /
      Executable includes:        Disabled
      Transcode via SLIN:          Enabled
      Internal timing:            Enabled
      Transmit silence during rec: Disabled
      Generic PLC:                Enabled

    • Subsystems
        -------------
        Manager (AMI):              Disabled
        Web Manager (AMI/HTTP):      Disabled
        Call data records:          Enabled
        Realtime Architecture (ARA): Disabled

    • Directories
        -------------
        Configuration file:         
        Configuration directory:    /conf/asterisk
        Module directory:            /usr/pbi/asterisk-i386/lib/asterisk/modules
        Spool directory:            /var/spool/asterisk
        Log directory:              /var/log/asterisk
        Run/Sockets directory:      /var/run/asterisk
        PID file:                    /var/run/asterisk/asterisk.pid
        VarLib directory:            /usr/pbi/asterisk-i386/share/asterisk
        Data directory:              /usr/pbi/asterisk-i386/share/asterisk
        ASTDB:                      /var/db/asterisk/astdb
        IAX2 Keys directory:        /usr/pbi/asterisk-i386/share/asterisk/keys
        AGI Scripts directory:      /usr/pbi/asterisk-i386/share/asterisk/agi-bin



  • any news or suggestions ?  ::)



  • Not sure about voicemail but I keep logs and cdr after reboot. Still using 301/302 but no changes to them and 303+ externals are fine, no re-addition of demo extensions.

    Working nicely on fresh 2.1 with raid1 (shouldn't matter). I have 2 lans on LAN and OPT1 and set localnet for both to pfsense's IP on those nets. Also doing 1:1 on WAN VIP to OPT2 so thinking of trying to get SIP to pass through tot that on a theoretical setup where pfsense handles some lans and passes an external IP to another lan that has it's own asterisk for whatever reason or just one phone talking to another outside asterisk or provider that has to be on 5060 as well.

    Is there  any explanation as to why jitterbuffer is on for PFSENSE's asterisk? I get why allowguest isn't… just curious about jitterbuffer.



  • Well I finaly figured it out

    In /usr/local/pkg
    there is the a file called asterisk.inc
    It contains the following code wich is causing my issue of the demo extentions being added after a reboot

    ==>

    if (strpos($script_file,'demo extension for pfSense') === false) {  //first check if already added…
                                    $add_demo_extension = << <eof<br>[301]
    ;demo extension for pfSense
    type=friend
    defaultuser=301
    insecure=port,invite
    secret=1234
    regexten=301
    host=dynamic
    context=default

    [302]
    ;demo extension for pfSense
    type=friend
    defaultuser=302
    insecure=port,invite
    secret=1234
    regexten=302
    host=dynamic
    context=default

    EOF;
                                    $script_file .= $add_demo_extension;
                                    file_put_contents($script, $script_file, LOCK_EX);
                            }
    <==

    Please fix this in the next release
    Thanks in advance

    Kr

    :) :) :)</eof<br>



  • As a workaround, all you have to do is keep the comment line "demo extension for pfSense" present in the conf file, but delete the demos themselves. The script only checks for the string "demo extension for pfSense", if it's present, it doesn't add anything.

    I can't seem to reproduce this problem in my setup though. If I delete the whole thing, it keeps it deleted after reboot too.



  • Hello,

    I have a specific question concerning logging as my Asterisk seems to often miss the connection to my VoIP provider.
    How could I send the Asterisk logging to a syslog server (I have one running in my house) ?

    Another solution could be to send the logs to a USB stick. But how ?

    Tx for your help !



  • no one ?



  • To save logs to the USB stick I think it would be enough to just change the logdir path in asterisk.conf```
    astlogdir => /var/log/asterisk

    
    For a remote syslog server you can try some tips found on the internet: http://www.savelono.com/linux/configuring-asterisk-for-a-remote-syslog-server.html


  • Over here on pfSense-2.1-RELEASE-4g-amd64-nanobsd_vga after package installation console outputs:

    Parse error: syntax error, unexpected $end in /usr/local/pkg/asterisk.inc on line 389



  • HEllo ,
    In 2.1-RELEASE (i386)
    built on Wed Sep 11 18:16:22 EDT 2013
    FreeBSD 8.3-RELEASE-p11

    With clean package install i am wondering to activate the AEL module , but there is an error.

    nxtwall*CLI> module load pbx_ael.so
    Unable to load module pbx_ael.so
    Command 'module load pbx_ael.so ' failed.
    [Feb 10 11:18:17] WARNING[92895]: loader.c:481 load_dynamic_module: Error loading module 'pbx_ael.so': /usr/pbi/asterisk-i386/lib/asterisk/modules/pbx_ael.so: Undefined symbol "destroy_pval"
    [Feb 10 11:18:17] WARNING[92895]: loader.c:894 load_resource: Module 'pbx_ael.so' could not be loaded.

    Thanks for your help.

    Regards



  • I never used pbx_ael.so module. I guess it depends on something, which is missing. Perhaps googling on the error message could give some hints…



  • I just upgraded my pFsense to the latest 2.1.2 release….
    After the reboot & successfull update pFsense gave me the following message "Packages are currently being reinstalled in the background."

    Nice !

    I have 2 packages....a small one (CRON) and Asterisk.
    The problem is the size of the new Asterisk package that is automatically installed !!!!!

    • previous release - asterisk-1.8.25.0-i386.pbi  -> 41MB
    • current release - asterisk-1.8.26.1-i386.pbi -> 108MB

    At the end of the installation Asterisk burns 580MB of space which leaves my 1GB CF card....voiceless...as my VoIP installation.

    In fact even with a 2GB CF card it has been problematic for me to install it.
    88% space used & installation goes forever. Then reboot, install the package again (in fact it will just run the installation phase not the download) and finally....it works ! But my card is nearly full with 88% of 907M used.

    Is there a reason for such a size increase ?
    What would be the way for installing the older release instead ?

    Thanks for your help.



  • Hmm…

    I also noticed that on my 4G CF card the space usage was higher after the upgrade, but I thougt that was because I was also upgrading architecture from i386 to x64. Your post shows me that I was most probably wrong.

    As far as I can remember the older Asterisk had some security issues, so the upgraded version is recommended to be used. However it's indeed surprising more than twice disk space to be used.
    The older asterisk had quite a lot of non-functional modules, because of many missing dependencies. Maybe here these were fixed, that would explain the increased disk space requirerements.

    I don't know.

    However, I suggest to move to 4GB card on NanoBSD...



  • @robi:

    As a workaround, all you have to do is keep the comment line "demo extension for pfSense" present in the conf file, but delete the demos themselves. The script only checks for the string "demo extension for pfSense", if it's present, it doesn't add anything.

    I have the same behaviour here and using your workaround does the trick.
    But it is annoying….



  • Hello ,
    I am using Asterisk package in the new Pcengines APU board with Pfsense 2.1 .
    I am searching to use Codec G729  ?  there is someone who try it?

    Regards

    Daniel



  • I think i need to recompile the sources  from here http://asterisk.hosting.lv/ 
    in a FreeBSD 8.0 system , with the linux compatibility ( Pfsense 2.1 doenst)

    Tell me if i am in the right way !!

    Thanks for your help

    Regards

    Daniel



  • Hi All,

    Does somebody tried the odbc connector from pfsense to another host?
    I'm trying to configure it (to use a remote mysql server as dialplan backend) but can't configure properly the odbc on pfsense.
    After adding the driver and the DSN, with isql I receive segmentation fault.
    It is a missconfiguration or bug?



  • I have a IPSEC VPN connections between 2 locations.

    Location 1 Has a pfsense router (10.0.1.254) with a dedicated Asterisk server (10.0.1.2) behind the routers LAN port.

    Location 2 is a pfSense Netgate router with Asterisk installed on the router (10.0.9.254)

    At location 2 anything behind the Netgate router LAN port (10.0.9.254) ipsec traffic travels to Location 1 (10.0.1.0/24) fine with out issues. But from inside the Netgate router (10.0.9.254) either via trying to ping in the GUI or ssh the Location 1's network (10.0.1.0/24)  no packetes travel down the VPN.

    So my issues is that I have short codes (ie *80) to dial the two locations but since Asterisk is not using the VPN tunnel on the Location 2 Netgate router (10.0.9.254) they time out.

    I need to find out how to get Asterisk from Location 2 to communicate down the VPN. Right now it simply does not even see the 10.0.1.0/24 network at location 1 from inside the router.

    Any idea how to get inner office extension to work over vpn? My other locatios with dedicated Asterisk servers behind the router/firewall work fine. I can not get any location with asterisk as an add on to register as a sip peer over the vpn



  • Is anyone else having issues installing the Asterisk package?

    pfSense version: 2.1.5-RELEASE (amd64)
    Asterisk package details: Beta - 1.8.26.1 pkg v0.3.3 - platform: 2.0

    Beginning package installation for Asterisk .
    Downloading package configuration file… done.
    Saving updated package information... done.
    Downloading Asterisk and its dependencies...
    Checking for package installation...
    Downloading https://files.pfsense.org/packages/amd64/8/All/asterisk-1.8.26.1-amd64.pbi ...  (extracting)
    Verifying Checksum...SKIP_ARCHLINES: 62
    Archive checksum: 58be47139e05fac3450d80a4b884ba9c89015eb775d7af0e22880b7f382f991c
    Saved checksum: b2a19cd1ee8711e4794554d58c065a9471ab3637d5b1b1340e2bd0060ac648d5
    pbi_add: /tmp/apkg_asterisk-1.8.26.1-amd64.pbi failed checksum, the archive may be corrupt.
    of asterisk-1.8.26.1-amd64 failed!

    Installation aborted.Removing package…
    Starting package deletion for asterisk-1.8.26.1-amd64...done.
    Removing Asterisk components...
    Menu items... done.
    Services... done.
    Loading package instructions...
    Include file asterisk.inc could not be found for inclusion.
    Deinstall commands...
    Not executing custom deinstall hook because an include is missing.
    Removing package instructions...done.
    Auxiliary files... done.
    Package XML... done.
    Configuration... done.
    done.
    Failed to install package.

    Installation halted.

    Even though it's only meant for pfSense 2.0, is that because I'm running 2.1.5 the issue here?



  • Hello,

    I'm not installing it on AMD but on my Alix system I also run pFsense 2.1.5
    As you maybe read in my earlier posts I had a lot of trouble installing that new Asterisk version. Main cause was storage:

    • short of storage (this version consumes 580GB)
    • speed of storage. On a low speed CF card install nearly always failed and had to be resumed.

    But finally it succeeded and runs ok.



  • @chercheur:

    Main cause was storage:

    • short of storage (this version consumes 580GB)

    Is that a typo? 580 gigabytes?



  • The Asterisk 1.8 package is not working\installing correctly under PFsense 2.2 i386 nanobsd (4 Gig dist) :(
    I am trying to install on an Alix board (alix2d13).
    Installing through the web interface does not seem to be the right way because this takes so long the web browser times out.
    So I also tried to install the package using the console (pfSsh.php playback installpkg Asterisk)
    The package seems to install correctly, but after the installation is done I am unable to start the service using de webinterface.
    When starting Asterisk using the console by starting /usr/pbi/bin/asterisk as root, the service starts and Asterisk is running fine. It Does not seem to be an Asterisk configuration issue (this also happens with de default Asterisk config)



  • Some additional info
    It looks like de asterisk.inc file is not executed correctly
    After a reboot, /var/log/asterisk for example is not created

    Here also some logging after the manual start as root from the console

    [Jan 26 20:34:01] NOTICE[-1] cdr.c: CDR simple logging enabled.
    [Jan 26 20:34:02] WARNING[-1] db.c: Unable to open Asterisk database '/var/db/asterisk/astdb': No such file or directory
    [Jan 26 20:34:02] NOTICE[-1] loader.c: 162 modules will be loaded.
    [Jan 26 20:34:02] WARNING[-1] loader.c: Error loading module 'res_snmp.so': Shared object "libperl.so" not found, required by "libnetsnmpmibs.so.30"
    [Jan 26 20:34:03] WARNING[-1] res_fax.c: 'modems' setting 'V17,V27,V29' is no longer accepted with 'minrate' setting 2400
    [Jan 26 20:34:03] WARNING[-1] res_fax.c: 'minrate' has been reset to 4800, please update res_fax.conf.
    [Jan 26 20:34:03] NOTICE[-1] pbx_lua.c: Lua PBX Switch loaded.
    [Jan 26 20:34:03] WARNING[-1] loader.c: Error loading module 'res_snmp.so': Shared object "libperl.so" not found, required by "libnetsnmpmibs.so.30"
    [Jan 26 20:34:03] WARNING[-1] loader.c: Module 'res_snmp.so' could not be loaded.
    [Jan 26 20:34:04] NOTICE[-1] res_smdi.c: No SMDI interfaces are available to listen on, not starting SMDI listener.
    [Jan 26 20:34:04] WARNING[-1] db.c: Unable to open Asterisk database '/var/db/asterisk/astdb': No such file or directory
    [Jan 26 20:34:04] WARNING[-1] db.c: Unable to open Asterisk database '/var/db/asterisk/astdb': No such file or directory
    [Jan 26 20:34:04] WARNING[-1] db.c: Unable to open Asterisk database '/var/db/asterisk/astdb': No such file or directory
    [Jan 26 20:34:04] WARNING[-1] db.c: Unable to open Asterisk database '/var/db/asterisk/astdb': No such file or directory
    [Jan 26 20:34:04] WARNING[-1] db.c: Unable to open Asterisk database '/var/db/asterisk/astdb': No such file or directory
    [Jan 26 20:34:04] WARNING[-1] db.c: Unable to open Asterisk database '/var/db/asterisk/astdb': No such file or directory
    [Jan 26 20:34:04] WARNING[-1] db.c: Unable to open Asterisk database '/var/db/asterisk/astdb': No such file or directory
    [Jan 26 20:34:04] WARNING[-1] db.c: Unable to open Asterisk database '/var/db/asterisk/astdb': No such file or directory
    [Jan 26 20:34:04] WARNING[-1] db.c: Unable to open Asterisk database '/var/db/asterisk/astdb': No such file or directory
    [Jan 26 20:34:04] WARNING[-1] db.c: Database unavailable
    [Jan 26 20:34:04] NOTICE[-1] cel_custom.c: No mappings found in cel_custom.conf. Not logging CEL to custom CSVs.
    [Jan 26 20:34:06] WARNING[-1] db.c: Unable to open Asterisk database '/var/db/asterisk/astdb': No such file or directory
    [Jan 26 20:34:06] WARNING[-1] db.c: Database unavailable
    [Jan 26 20:34:06] WARNING[-1] db.c: Unable to open Asterisk database '/var/db/asterisk/astdb': No such file or directory
    [Jan 26 20:34:06] WARNING[-1] db.c: Database unavailable
    [Jan 26 20:36:11] WARNING[-1] db.c: Unable to open Asterisk database '/var/db/asterisk/astdb': No such file or directory


Log in to reply