PS3 - no connection to online server?


  • Hi guys,
    i know there are already a lot of posts/solutions for ps3/pfsense issues, but nothing seems to work for me?!

    I have the following network:

    WAN - Fritzbox - PFSENSE 2.0.1 - some switchs - PS3

    The PS3 has the static IP: 192.168.0.82 (NAT type 2, UPNP unavailable although it's activated). I can connect without any problems to the PS Network store and surf with the PS3 Browser. But when starting Fifa 11 for example, it says "Can't connect to EA Server" (or something like that, it's the german version). The same for Little Big Planet 2 -> "A problem occured while connecting to the server (403)".

    When connecting the PS3 directly to the Fritzbox it works. I also diabled the Firewall in PfSense, but I still got the error messages.

    PfSense Settings:
    LAN Subnet: 192.168.0.0
    No DHCP Server, all clients have static IPs

    NAT - Outbound:

    • Set to Manual Outbound NAT rule generation (AON - Advanced Outbound NAT)
      and edited the created rules to static port so that it looks as follows:

    WAN   192.168.0.0/24 * * 500 * * YES  Auto created rule for ISAKMP - LAN to WAN  
    WAN   192.168.0.0/24 * *  *    * * YES  Auto created rule for LAN to WAN  
    WAN   127.0.0.0/8      * *  *  * 1024:65535 NO Auto created rule for localhost to WAN

    I also created the following LAN rules (as far as they didn't already exist):
    TCP LAN net * * 80 (HTTP) * none
    TCP LAN net * * 81 * none
    TCP/UDP LAN net * * 3478 (STUN) * none
    TCP/UDP LAN net * * 3479 * none
    UDP LAN net * * 3658 * none
    TCP LAN net * * 5223 * none

    UPnP & NAT-PMP Settings:
    Enable UPnP & NAT-PMP: checked
    Allow UPnP Port Mapping: checked
    LAN Interface selected.

    I tried User specified permissions as well, but without success.

    The problem has to be connected to pfsense. I connected the PS3 directly to Pfsense and it didn't work…

    Could the not functioning UPnP be the reason for everything? But when NAT says type 2, shouldn't it work anyway?

    Best regards!

    edit
    I just found a long list of Ports, that are used by Fifa 11 and created rules for them. Afterwards the PS3 was able to connect to the EA Server. It seems as UPnP necessary for PS3 online play.. But I don't get why it hasn't worked before when the firewall was "disabled"...


  • This would be similar to the Xbox 360?
    http://forum.pfsense.org/index.php/topic,43624.0.html