OpenVPN client timing out in Windows 7



  • Hello,

    I have a user running Windows 7 64 bit who is complaining that their OpenVPN client keeps appearing while they're working, asking for username and password again.  They then have to re-login to their application.  I am logging 'Inactivity timeout (–ping-restart)' on the pfSense.  I've tried adding the 'keepalive 30 3600;' option to the OpenVPN server config, but this means the user's connection only lasts an hour.  I am assuming the Windows 7 firewall is blocking OpenVPN's keepalive packets?  Windows 7 is showing the TAP adapter as a 'Public Network'.

    Todd



  • guessing you have "auth-nocache" in the client config, which will do what you describe by design.



  • Hello,

    Yes, you're right, I do have the 'auth-nocache' option enabled, I'll disable this.

    Thanks,

    Todd



  • Thank You!
    I was going to post about this issue, but I always use "auth-nocache" option as recommended by OpenVPN client :)
    I was thinking this is about communication issue (temporary time-out) or so. Or I was going to use TCP instead of UDP to fix this.


Log in to reply