Tengo problemas con las vlans y el pfsense???



  • saludos a todos buenas noches….
      1.- Tengo 4 swicth :Un Capa 3 (3750G) y 3 capa 2(2960 ) .
            - el swicth layer 3 tiene una configuracion vtp server y los 2960 tienen configuracion vtp cliente,en donde en el edificio hay 3 pisos ,cada piso representa una vlan...el detalle actualmente todo el edificio tiene conectividad por medio de un backbone de fibra..,se hizo la configuracion de un puerto trunk comun en este puerto aqui esta conectado el pfsense....todo el edificio tiene internet por la lan 192.168..1.1.? se crearon las vlan en el pfsense y en el swicth ....se tomo un puerto 5 gigabit del swicth y se creo un acceso a la vlan 2 ...tome una pc la conecte al puerto y me dio ip 192.168.2.115 ,tengo acceso a la 192.168.1.1 pero no tengo internet ....me puede ayudar  a solucionar ...mil gracias..



  • Cada VLAN es una interfase más en pfSense y debe tener sus reglas de paso hacia internet.

    Con la 2.0.x tienes también Floating rules que te permiten definir reglas para todo el cortafuegos. Eso puede evitarte repeticiones en cada interfase.

    Tener presente también que después de definir las VLANs conviene reiniciar switch y cortafuegos para evitar líos. No siempre es necesario pero…

    Hace unos días pusimos un hilo arriba de este foro, donde dice Documentación sobre VLAN.

    Saludos,

    Josep Pujadas-Jubany



  • Muchas gracias bellera ,pero todavia no he logrado conectividad …desde  el pfsense con direccion de la vlan 2 puedo hacer ping a cualquier direccion externa y me resuelve ?? ... en la opcion diagnostics --ping ..?el detalle esta es que no hay comunicacion ..con el resto de las vlan...?



  • Para que una LAN (o VLAN) comunique con otra tienes que poner reglas específicas…

    Ejemplo:

    • En LAN, de LAN a LAN2
    • En LAN2, de LAN2 a LAN

    Puedes empezar con una regla en LAN que permita todo de LAN a LAN2 y otra en LAN2 que permita todo de LAN2 a LAN, para probar.

    Después dejas sólo lo que te interese...



  • buenos dias , amigo bellera hice las pruebas con la reglas: de lan con  lan2 ; lan2 con lan y nada de conectividad ???todavia no he logrado encontrar las fallas ..he realizado muchos descartes y hasta lo momentos nada..?muchas gracias por el apoyo recibido ..?



  • A ver, ¿tu switch admite VLANs por etiquetado?

    ¿Etiquetaste correctamente tanto en tu switch como en pfSense?

    ¿Reiniciaste todo después?

    http://forum.pfsense.org/index.php/topic,47388.0.html



  • voy a probar ?? muchas gracias



  • Hola  luisj8:

    Yo tengo una instalación parecida a la tuya, aunque más complicada. Mi caso lo he resuelto incluyendo la máquina pfsense en una de las vlans, donde están los servidores.

    Te voy a indicar como lo tengo hecho, para lo que te mando un esquema de mi red:

    • He generado las vlans en los switchs (usando VTP o como quieras) y he colocado cada equipo en su vlan correspondiente, el pfsense como un equipo más en su vlan.
    • He generado en el switch L3, un interface para cada una de las vlans creadas, que realizarán las funciones de gateway para cada una de las vlans.
    • He configurado (en cada equipo) como gateway, el interface (creado en el paso anterior) de la vlan a la que pertenece.
    • He activado el routing el el switch L3 y le he añadido como gateway (ruta por defecto) la IP LAN del pfsense.
    • He añadido al pfsense una ruta por cada vlan (excepto a la que pertenece el pfsense) que envíe los paquetes al interface  de la vlan en el switch L3 a la que pertenece el pfsense.

    Con todo esto, todos los equipos se comunicarán entre si y con Internet. Para controlar las com. entre las vlans podrás usar las ACLs en el switch L3, y para las com. con Internet el pfsense.

    Espero que todo esto te sirva, un saludo.



Log in to reply