Issues with 1.2-BETA-1-TESTING-SNAPSHOT-04-30-07



  • 1.2-BETA-1-TESTING-SNAPSHOT-04-30-07
    built on Tue May 1 04:01:05 EDT 2007

    We just upgraded 2 PfSense nodes running in a CARP failover configuration to this version. Since then we have a very major issue: we can't add or delete any aliases or rules.
    When I delete an alias or a rule it is removed from the list but as soon as I press "Apply changes" it will appear again. Same is true for adding stuff. It shows up but after "Apply changes" is pressed it disappears.

    Please help, the units are unusable this way. :'(



  • I am having trouble recreating this issue.  I just edited an alias and it applied okay and duplicated a rule and applied.  In both cases the rules are as they should be.

    Chances are somehow your configuration has been corrupted.  Please either forward config.xml to sullrich@gmail.com or reinstall.



  • I just mailed you the config.xml of both nodes.



  • When creating a CARP cluster you do not want to sync the backup node to the primary node.

    This creates a endless sync loop where the changes constantly overwrite each other.  I have removed the sync settings on the backup node and all is well.



  • Thank you SO much! :)

    My bad then, I thought in order to make the whole sync process work I was required to enable the same sync options on both nodes.
    Maybe it would be a good idea to put a little note under the sync options to tell everybody not to enable them on the secondary but only on the primary?

    Anyways, thanks again for your very fast help!



  • I have added code which will prevent this loop from occurring and log a message when it does.


Log in to reply