Pfsense https lent



  • Bonjour à tous,

    nous rencontrons un problème avec pfSense au niveau de l'https pour le portail captif.

    En fait, on a créé un certificat pour notre serveur pfsense et tout fonctionne.

    Le seul problème est que le chargement de la page d'authentification est très lent, environ 15 secondes au minimum.
    Si on désactive le https, le chargement est instantané. Ce qui est certain, c'est qu'en théorie le https prend évidemment plus de temps pour charger mais à ce point là j'en doute.
    Les navigateurs sont configurés de la même manière.

    Quelqu'un a t-il déjà eu ce problème ? Ca ne doit pas être grand chose mais nous bloquons un peu.

    Merci d'avance !



  • Vous avez généré un certificat auto signé ?



  • non, il n'est pas auto-signé



  • Bon, on a trouvé le problème, en fait sur les navigateurs, il y a l'option OCSP qui est activé par défaut (dans mozilla : préférences, avancé, chiffrement, validation).

    Cette option réalise une requête en https sur Internet pour vérifier si le certificat n'est pas révoqué, et vu que le portail captif est activé, la requête n'aboutie pas. Au bout de quelques secondes (15 environ pour nous), le navigateur annule la requête et affiche la page.

    Il faudrait donc configurer sur pfSense une règle qui laisse passer cette requête, je vais voir si c'est réalisable.



  • C'était bien le sens de ma question.



  • savez-vous si cela est réalisable ?

    màj : bon en fait on a réussi dans les paramètres du portail captif dans "Alloweb IP adresses" (option qui permet d'ajouter des adresses IP sur lesquels on peut se connecter sans forcément s'authentifier avant). Dans le certificat SSL, il faut regarder l'adresse web OCSP (ex : https://blablabla.verisgn…), ensuite tu fais un nslookup de cette adresse pour récupéré son adresse IP et tu as plus qu'à la mettre dans "IP Adress".

    J'espère que ça pourra servir à d'autres !

    A+ !


Log in to reply