Cannot get WAN IP automatically in ESXi



  • First time to post here, sorry for my poor English~

    I've an ESXi machine and a pfSense box at home, and two WAN connections at 200Mbps and 100Mbps.

    The pfSense box is running fine, however I'm trying to move the pfSense to a VM in the ESXi and faced a problem.

    The standalone pfSense box can get the WAN IP automatically on start and when the cable plug in, which I considered it to be normal.

    However, in the VM pfSense, when the cable plug in, the web configurator interface shown a green up arrow, while the IP remains 0.0.0.0

    It will not get the IP correctly, no matter how I renew the IP.

    But, if I reboot the VM pfSense in ESXi, it can get the IP correctly.

    This issue also happened when I reboot the ESXi, and let the VM pfsense auto start, 0.0.0.0 for the WAN, until I reboot the VM pfsense in ESXi manually.

    My setup:
    ESXi

    pfsense
    (E1000 as LAN and Vt-d passthrough an Intel ET dual port card as the two WAN interface)
    Ubuntu



  • Have you ever tried to disconnect the 'virtual network cable' instead of the real one?

    The running vm doesn't really get it when you disconnect the physical cable.



  • How can I disconnect the virtual cable? Do you mean in ESXi?



  • Just go into the settings of the vm and choose the networkadapter.
    Uncheck 'connected' - click OK.
    Again into the settings of the vm - choose networkadapter - check 'connected' - click OK.

    I've just seen that you have the WAN interface connected as a passthrough device. This interface can unfortunately not be separated virtually.



  • Is there a particular reason you passthrough the Intel ET card to pfSense rather than letting ESXI virtualize the WANs?

    It may be worth a try.


Log in to reply