PfSense + sqid+squidguard + radius doesn't work



  • Hello All!
    I created a firewall with pfSense and I installed squid, squidguard and "captive portal radius." First I created the captive portal with radius and working properly.
    Then I installed squid as "trasparent proxy" and it worked well.
    I saved and rebooted and no longer works on pfSense captive portal: returns me the error: "500 internal server error". >:(
    How can I fix? ???
    Thanks for the help



  • Don't think they work together, yet. I was directed to put squid elsewhere if I wanted to us captive portal. I believe someone was woking on it for 2.1 but not sure.

    Try without transparent see if that works?  :-\



  • Hi,

    CP and transparent-squid is working as far as I know.
    CP and non-transparent-squid is not working because the user bypasses the CP.
    But even if it is the one or the other way it is not related to the 500 error I think.

    Can you disable and re-enable the CP and test again ?
    Try if it works if your browse directly to the cp:
    http://pfsense_ip:8000



  • hi!
    nothing. I disabled and re-enabled the cp but it doesn't autenticate me. Radius doesn't respond.
    If I disable the CP he gives me instant acces to web and squid works well;
    if i disable quid and squidguard and enable the cp i still can't autenticate..
    but at the beguinning of my work i tested the freeradius and worked well..
    where is the mistake?  ??? ??? ???



  • @Mazzokun:

    hi!
    nothing. I disabled and re-enabled the cp but it doesn't autenticate me. Radius doesn't respond.
    If I disable the CP he gives me instant acces to web and squid works well;
    if i disable quid and squidguard and enable the cp i still can't autenticate..
    but at the beguinning of my work i tested the freeradius and worked well..
    where is the mistake?  ??? ??? ???

    make sure that CP and freeradius can communicate and authentication works. reboot, try again. if all is ok try with squid and test again.

    So probably it is the best to do a fresh configuration of your pfsense.



  • ok i caught the problem. I was useing DNS Forwarder.
    How can i set dns forwarder to work with cp and freeradius?



  • I set up a NAT rule to catch all DNS requests on port 53 and to have it go to the DNS forwarder on my pfsense box.  That means no matter what someone may have manually set their DNS server to, all DNS requests go through the router and then captive portal can properly redirect any outgoing web requests for authentication.


Log in to reply