Non riesco a connettermi ad un DVR



  • Ciao a tutti.

    Ho 2 LAN, separate da un firewall PFSense.

    La prima LAN (LAN1) usa il firewall come DHCP e ha subnet 192.168.55.XXX.
    Su questa LAN il firewall ha indirizzo 192.168.55.1

    La seconda LAN (LAN2, che fantasia :P) ha il suo server DHCP (192.168.66.1) che assegna staticamente l'indirizzo 192.168.66.2 a PFSense.

    Devo fare in modo che i client di LAN1 riescano a connettersi al DVR collegato a LAN2.
    il DVR ha indirizzo 192.168.66.100, anche questo assegnatogli staticamente.

    Ho provato così:

    TEST A:

    • nel programma che uso per accedere al DVR inserisco l'ip del DVR così, nudo e crudo. esito negativo

    TEST B:

    • ho creato un virtual ip su LAN1 (192.168.55.100)
    • ho impostato un NAT 1:1 tra il virtual IP e l'ip del DVR (LAN1 192.168.55.100 192.168.66.100 *)
    • provo ad usare l'ip virtuale -> esito negativo.

    Se provo a connettermi da LAN2 tutto fila liscio come l'olio

    Il firewall non penso ci sia bisogno di toccarlo in quanto entrambe le LAN hanno piena visibilità l'una dell'altra

    idee?



    1. entrambe le lan hanno come gateway pfsense?
    2. hai provato tracert da lan 1 a lan2 (e viceversa) ?
    3. per provare hai messo la regola da lan1 a lan2 pass tutte le porte e protocolli?


  • @LonelyWolf:

    1. entrambe le lan hanno come gateway pfsense?

    No. LAN2 ha il proprio gateway che fa anche da DHCP

    @LonelyWolf:

    1. hai provato tracert da lan 1 a lan2 (e viceversa) ?

    Sì, gli instadamenti sembrano funzionare

    @LonelyWolf:

    1. per provare hai messo la regola da lan1 a lan2 pass tutte le porte e protocolli?

    LAN1 la aveva già. l'ho messa anche a ritroso (allow LAN2 to any) giusto x provare, nessun effetto.

    Cmq ieri sera ho riavviato il router ed adesso sembra funzionare. Possibile che PFSense si sia "incantato"? Ho messo un virtual IP per ogni HOST + NAT 1:1



  • Possibile, ma non certo.
    Cmq anche io avevo problemi da lan2 a lan1 non essendo pfsense il gateway, è stato sufficiente inserire una route statica nei client in entrambe le lan (ovviamente solo a quelli che necessitano comunicazione).



  • @LonelyWolf:

    Possibile, ma non certo.
    Cmq anche io avevo problemi da lan2 a lan1 non essendo pfsense il gateway, è stato sufficiente inserire una route statica nei client in entrambe le lan (ovviamente solo a quelli che necessitano comunicazione).

    nel mio caso la route statica non é stata sufficiente.
    aggiungendo il virtual ip tutto s'é messo a funzionare a dovere (dopo il riavvio)

    ora ho pure tolto la regola "allow LAN2 to any" dal firewall e tutto sembra cmq funzionare.

    il NAT ingora le regole del fw?

    scusate ma non sono granché pratico di networking :\


Log in to reply